cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Automation Master
Automation Master

Error querying Excel Services

Hi,

 

I have tried to configure the Query Excel Service.

When I run it from the configurator, sometimes it gives back the content of the cell, sometimes it gives me the following error:

"The execution returned an unexpected error.

The request failed with HTTP status 401: Unauthorized."

When I run it from the Workflow Start page, it gives me always this error

'Error querying Excel Services. The request failed with HTTP status 401: Unauthorized'

 

The Trusted Excel Location is http://

 

In the UAT environment, it never gives back any value. The Trusted Excel Location is http://

 

Because it is not the first time this question was asked in the Nintex Forum, does anybody have succeded to run this Nintex action with stability.

 

If not, did you use a workaround like copy the content of the excel in a list?

 

Best regards,

 

Christophe

Labels: (1)
Tags (1)
0 Kudos
Reply
2 Replies
brad_orluk
Nintex Newbie

Re: Error querying Excel Services

Hi Christophe,

This type of error is usually only thrown if there is some sort of issue with the underlying SharePoint infrastructure (e.g. how the Farm is configured in terms of the webapp and various services such as Excel).

To understand a bit further can you tell me what version of SharePoint you are using (20xx and CU) as well as the version (build #) of Nintex Workflow as well as which type of data you are attempting to pull from the spreadsheet.

Best,

Brad

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Error querying Excel Services

To isolate Nintex action from the equation ..would you please try the SharePoint powershell command to query the Excel service. Please see this link for guidance: WIDBA: Saving an Excel workbook using Excel Services and Powershell on Sharepoint 2013

 

Cheers,

Majid

0 Kudos
Reply