K2 Settings looking at wrong server on SharePoint

  • 5 August 2015
  • 0 replies
  • 13 views

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Symptoms


Issue:
After restoring a SP content DB from Production to QA environment, the user, that has permissions on the QA site is not able to start the workflow. However the user that has the rights in Production is able to do so, therefore it seems like QA is still synced with Prod.
 

Diagnoses


Diagnosis:
We ran a reconfigure on K2 Blackpearl and SharePoint on both the QA server and the QA SP server.
Checked the Hostserver.Server and the Server.Server tables and they were pointing to the QA.
Double checked that the client is deploying to QA in K2 Studio.
Double checked that the Production and QA servers have 4.6.7 all across.
Open the SPM 2010 and checked the hidden K2 lists - they were also pointing to the QA.
 

Resolution

Workaround:
Creating a new site and associating the workflow with a new library solved the issue. The QA user is able to start the Workflow and the solution runs as expected.




 

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