cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Domain stripped out of href in email body

Jump to solution

Nintex Workflow for SharePoint 2010. I'm editing HTML in an email body. I'm inserting an anchor tag...

 

<a href="http://www.mydomain.com/my-app/my-page.aspx">View your stuff</a>

 

But as soon as I switch from the HTML view, the editor strips out the domain information so that all I have left is...

 

<a href="/my-app/my-page.aspx">View your stuff</a>

 

...which isn't at all useful for an email.

 

Any thoughts on how to insert a URL and have the editor leave it alone?

Labels: (1)
0 Kudos
Reply
4 Replies
Not applicable

Re: Domain stripped out of href in email body

Jump to solution

Hi Jeff,

I assume that "/my-app/my-page.aspx" is one of the page in your SharePoint site. Hence what cyou can do is, use the workflow context <WebURL> in you mail and append the relative url of the my-page.aspx.

Ex: If you are working ina site http://www.mydomain.com. In the anchor tag in href you caa use the below format:

{Common:WebURL}/my-app/my-page.aspx

You will find weburl in common section of the workflow context.

Capture.PNG

0 Kudos
Reply
Workflow Hero

Re: Domain stripped out of href in email body

Jump to solution

Hi Nidish,

Thank you for your reply. This is indeed a page in my sharepoint site.

Using {Common:WebURL}/my-app/m-page.aspx does not seem to be working for me, but maybe I'm using it incorrectly? As soon as I return from the editor they re-examine the HTML it looks incorrect, and link doesn't work in the email. For example if I put this in my HTML:

<a href="{Common:WebURL}/my-app/my-page.aspx">View your stuff</a>

When I return to the editor then return to the HTML view I see:

<a href="/my-app/_layouts/NintexWorkflow/%7BCommon:WebURL%7D/my-app/my-page.aspx" target="_blank">View your stuff</a>

And the actual URL in the email ends up being http://www.mydomain.com/my-app/my-app/my-page.aspx.

I have discovered however that if I simply use the editor's insert link feature things do work out correctly, and with the added bonus that I can see the hyperlink in the editor (underlined, and in blue) whereas if I only have anchor tag (which I can't seem to get to work anyway) there is no indication in the editor that a hyperlink is present.

So for now I have a solution that works for me.

0 Kudos
Reply
Workflow Hero

Re: Domain stripped out of href in email body

Jump to solution

Jeff, it sounds like you're going directly into the html editor of the email to add your link.  Instead of doing that, from the WYSIWYG editor, on the ribbon there should be a tab called "Insert".  Click on the "link" option to insert a link.  You will get a pop up with two fields.  One for the address and one for the text to display.  Enter your full page address in the first, and enter "View your stuff" in the second.  Then click OK.  That will insert a properly formatted link, and won't truncate your address.  

0 Kudos
Reply
Workflow Hero

Re: Domain stripped out of href in email body

Jump to solution

Hi ‌,

did the solutions from Brendan and Nidish solved your "old" issue? If yes, could you mark one of their answer as correct so it could be useful for other user?

Thanks

Reply