cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Create item in another site "#;" errors

Hi all

When I use the [Create item in another list] workflow action, in order to copying an list item from one list (LIST A) to another list on another subsite (LIST B); the items fields derived from a look-up column on my source (LIST A) copy over into (LIST B) with "number;#" in front of my desired field data.

E.g say I intend to create a new list item in LIST B from LIST A as follows:

Note: [Text] = Single line of text or Multiple lines of text

LIST A:
Column Type, Column name, Data
*************
Lookup [Text], Product Code, PRD-224
Lookup [Text], Product Name and Code, PRD-224 (Box of cool stuff -RED)
Lookup [Text], Colour, Red
[Text], Description, "Simple but stylish box of cool stuff, items inside are red".

LIST B:

Column Type,Column name, Data
*************
[Text], Product Code, 32;#PRD-224
[Text], Product Name and Code, 32;#PRD-224 [Box of cool stuff -RED]
[Text], Colour, 14;#Red
[Text], Description, "Simple but stylish box of cool stuff, items inside are red".

Columns "Product Code", "Product Name and Code" and "Colour" on LIST A are lookup columns to another list (Product Catalogue list); after the workflow is run on a item on LIST A the result is these columns (and others) are created in LIST B with a "number;#" in front of the data.... I.e. in my example "14;#".

How can I stop this from happening?

I hope I have explained clearly?

Labels: (1)
0 Kudos
Reply
2 Replies
Workflow Hero

Re: Create item in another site "#;" errors

I can't replicate.

Can you screenshot your action configuration?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Create item in another site "#;" errors

Use the inline fuction parselookup(), which will extract only the display value of a list lookup.

0 Kudos
Accept as Solution Reply