cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Conditional startup options not working?

I've created a workflow that I would like to start on a condition that a field has changed.

Below is a screenshot of my workflow settings - Seems pretty simple, I'm comparing the previous value of the field to the current value of the field, and if they don't equal, the workflow should start. It's not working. What am I missing?



I've had other conditional start issues in the past, but I've just worked around them.

Thanks!

Labels: (2)
0 Kudos
Reply
5 Replies
Workflow Hero

Re: Conditional startup options not working?

Is this a reusable workflow or plain old list workflow? 

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional startup options not working?

Plain old list workflow.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional startup options not working?

On your form add a calculated value. Do you actually see the same field 'level of estimate' change its value.

Are you starting with a  blank value ? If so what happens if you start with field is empty and field is not empty ?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional startup options not working?

The field is required, so there will always be a value.  One of my workflows runs a switch based on this value, and when the "Level of estimate" changes, I want to re-run the workflow so it goes down the correct switch.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Conditional startup options not working?

Cassy,

Does it make a difference if a reusable workflow is used?  I"m running into a problem with start options using a site collection re-usable workflow template.

See >>  

Ken

0 Kudos
Accept as Solution Reply