cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Collection Operation Remove by Value Not Working

So this is probably a dumb question with an obvious answer, but I can't get the remove by value operation working. I have a collection with a number of entries that simply say "None". I want to remove them, but I can't seem to make it work. Help would be appreciated.

Labels: (2)
0 Kudos
Reply
10 Replies
Workflow Hero

Re: Collection Operation Remove by Value Not Working

Have you tried remove duplicates first

and then remove "None"

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

I just tried remove duplicates and that didn't even remove the duplicates. I must be doing something wrong here, I just don't know what.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

have you output your collection anywhere?  do you know what is in it?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

Later in the workflow I use build string from that collection, then set a field to that string. I can see what is in it through that.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

some screenshots may help here

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

Sure. Here are some that might be helpful.

The query where I output to the collection:

The collection operation:

And the output:

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

Looks to me like your Collection has line breaks in each value

So each one is:

"None

"

rather than "None"

Can you clarify in the source?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

The source does not have line breaks. I did go ahead and try the

"None

"

but it didn't work either.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Collection Operation Remove by Value Not Working

How do you fill this collection with its values - ie do you query a list?     Are you able to "trim" the values prior to putting them into the collection.   I suspect it is the whitespace following these, whereas value must match exactly.   

Accept as Solution Reply