Showing results for 
Search instead for 
Did you mean: 
Nintex Newbie

Coercion Failed on Create Item in site workflow, but item still created

I have a Nintex site workflow (2010) which is intended to copy data from a read-only external list into a SharePoint custom list for manipulation.

The workflow consists of the following steps:

1. Query list - get the data from the external list and store into a collection called items, using the unique field BCDID as the reference field, storing the result into the string variable BDCIdentity

2. For each item,

3. Create item in the custom SP list.

When I run the workflow, for each item, I receive an error: "Coercion Failed: Unable to transform the input lookup data into the requested type". 

However, the items are still copied as expected. All the items that I am trying to copy are Single Line of Text fields, in both the source and destination lists.

In the Create item configuration, the only option in the [...] box next to the field name is As String (default).  The [...] box next to the BCDIdentity field in the Equals section offers many options - I use the As String (default), but I have tried some others and still get the error. (for example, plain text, Lookup value as text), all without success.

Has anyone else experienced this?  How can the items be created even though the error occurred? 

Another issue is, how do I find out what is being transformed,and to what is it being transformed?

The items are getting copied, however I would like to figure this out, as I have over 40 fields to move ,and I don't want to create entries in the dialog for all of them without figuring this out first. I really don't want to release this to the user until it is error-free.



0 Kudos