cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
sonyab
Nintex Newbie

Checkbox not recognized as checked

Jump to solution

Hi all,

 

I feel like I'm missing something simple with my checkbox validation.

 

I'm using InfoPath 2013 to update a form that submits to a SharePoint 2010 library. We're using Nintex Workflow 2010.

 

I created a new checkbox in InfoPath with a field name of grantRelated. I added it to the Property Promotion and called it Grant Related, then published the form.

When opening the form in SharePoint, I saw my checkbox. However, Grant Related didn't show up as a column when modifying the library's view. Also, it didn't show up when adding a "Set a Condition" in Nintex.

 

So I went back out to the library and went to Library Settings and chose "Add from existing site columns." I saw Grant Related from the available site columns, so I chose it, clicked Add, unchecked "Add to all content types", left "Add to default view" checked, then clicked OK.

 

Now it's possible to select Grant Related as a column in the Library view, and it's also visible as a choice in Nintex.

 

I added a "Log in History list" to check the value of Grant Related, but the value always says False even if the checkbox is checked.

 

What have I done wrong?

 

Thanks for the help,

 

Sonya

Labels: (2)
0 Kudos
Reply
1 Reply
sonyab
Nintex Newbie

Re: Checkbox not recognized as checked

Jump to solution

I solved my own problem.

 

It turns out that the form was publishing to a different content type than what was associated with the library. Infopath was publishing to ContentType1 but the library was associated with ContentType2.

 

I found this out by going to the Library Settings in SharePoint and clicked on the default content type, which correctly said "ContentType1". I then noticed the "Parent" at the top of the screen and the "Source" column in the Columns section said "ContentType2".

 

To fix it, I went back to the form in Infopath 2013 > File > Publish > SharePoint Server > Next > Made sure Site Content Type was checked and clicked Next > Chose the ContentType2 and clicked Next > Next past the location > Made sure I had any new columns selected in the columns list and clicked Next > Clicked Publish.

 

Now my columns show up and my workflow recognizes my checkbox.

 

Whew.

0 Kudos
Reply