cancel
Showing results for 
Search instead for 
Did you mean: 
cmikhaiel
Nintex Newbie

Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

We are trying to fix a previous install  of Nintex 2016 where the SharePoint administration menus do not display in Central admin. 

I've uninstalled Nintex, retracted all the solutions, and ran all the powershell necessary to remove the broken install. Re-ran the wizard to re-install. The wizard ran fine but the issue is still re-occurring. No menus are appearing at all in Central admin. 

I've ran these commands https://community.nintex.com/community/support/blog/2015/01/13/problem-nintex-management-menus-are-n...

But I'm getting a message that the features are already enabled. 

There could be a history with the previous install that is causing this, but I don't know what could have happened to cause the install to fail - different user.

I appreciate any prompt response.. This is a scheduled/prod deployment and we're trying to get this fixed asap. I've contacted support, but I trust the awesome community might have a solution already for me..

Addition: May be it would be worth to mention that I'm running the installers on the server that has CA deployed. and the farm has 2WFE (that are also load balancers), 2 app servers, 2 DB, and another 2 server for an extra tier.  

addition 2: 

I"ve also noticed on the WFE server 2 (where central admin is deployed) that it had recently failed an attempt for an upgrade. I'm not sure if that is related or if it needs to be fixed first!

also pretended that I'll run the sharepoint configuration wizard, i noticed that all the Nintex solutions are unchecked by default! is there a way to enable those without having to run the config wizard?! if I check them all and run the config wizard in 2016, would that mess it up?!

Labels: (1)
Reply
5 Replies
cmikhaiel
Nintex Newbie

Re: Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

An Update: we ran the psconfig. and the WFE server upgrade was successful. when tried to re-run the installer wizrd. I'm getting this, we already have a license but i cannot get to central admin menus (not appearing) to update it. I tried export the solution and find any variable checking the validity of the license that can modified to run the installation manually, but the files for 2013 are different from 2016. 

‌, have you encountered something like this before?

0 Kudos
Reply
Automation Master
Automation Master

Re: Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

I've never been involved in installation before! This is new to me. 

0 Kudos
Reply
Nintex Employee
Nintex Employee

Re: Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

Really bizarre.  I think this might be easily resolved by reaching out to your Nintex Account Manager and getting updating license files.

Vadim

Reply
cmikhaiel
Nintex Newbie

Re: Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

After some sleepless nights of trying to uninstall Nintex.. re-install .. calls with support, running the server upgrades, checking the server files, changing the lines on the config file...etc.

We figured that the problem was due to the role of the server that we were running the install on.

Although it is a Web Front End (which hosts CA) but the role was set as "Custom". The business did the switch to WFE and they are saying that the menus appeared right after that... 

That never could have crossed my mind, and I don't know why would that prevent the menus in CA from showing and why would that cause those errors of the license. Something new was learnt the hard way!

Reply
Automation Master
Automation Master

Re: Central Administration menus are not visible in Nintex/SP 2016

Jump to solution

Thanks for sharing, Christine! That's going to help a lot of folks, probably!

0 Kudos
Reply