Installing K2 Connect on the client machine in a diferent path that in Server Machine




 

Symptoms



Issue: Installing K2 Connect on the client machine in a different path that in Server Machine

Issue is about the different path between the K2 connect installation in the server and client (developer machine). When configuring the connector in the server machine, the SourceCode.ServiceObjectModel.ERP.Connect.dll is in the "E:" Drive (which is a client requirement) , and when They configure the connector in the client machine for installing the developer tools the SourceCode.ServiceObjectModel.ERP.Connect.dll is in "C:" drive, when this is selected , the config tool says that the connector is invalid.
 

Diagnoses



Diagnosis:

After further Investigation It was found that the SAP Netweaver RFC Libraries and the librfc on the two machines (server and client ) i were present. as per the following documentation:

http://help.k2.com/onlinehelp/k2connect/userguide/current/default.htm_Quick_Install_Guide.htm?TocPath=Install|_____3

Client verified that the connector is correctly installed in the server environment (SAP server accessed a correctly).

The error of the connector is invalid states the following:
The selected File is not a regular K2connect Connector. Exception has been thrown by the target of an invocation

The following article was provided for the issue:
http://help.k2.com/onlinehelp/K2connect/UserGuide/current/default.htm_The_selected_File_is_not_a_regular_K2_connect_Connector.html

Side Note: The article resolution states that the older version of ERPConnect must be uninstalled and the GAC registration of the old file must be deleted as well. As the error is a result of when an older version of the ERPConnect assembly is still resident on the system where the K2 connect for SAP Service has been installed. This was not the case.

It was found in all the systems that the ERPconnect dll (two with 1.0 version and one with 4.29 version). The 4.29 version is in the installation drive root folder of the three machines but not in the GAC of the clients machine

 

Resolution


Resolution:

The following articles were used for the install:

1. http://help.k2.com/onlinehelp/K2connect/UserGuide/current/default.htm_Quick_Install_Guide.htm?TocPath=Install|_____3

2. http://help.k2.com/kb000860

The K2 connect component was installed on the two server machines, Dev and Prepod and on one client machine (the machine for the developer tools). For all three machines K2 connect for SAP for 4.6.11(4.10060.870.0).exe was only installed as per the above documentation

The Dev and PreProd machines had the same DLL's registered in the GAC (1.0 version and 4.29 version). while the client machine only GAC only Had ERPconnect dll (1.0 version). Registering the DLL manually in the client machine allowed the machine to be configured. Also noted that the the old DLL'S were not deleted or removed and error as mentioned above did not occur




 

0 replies

Be the first to reply!

Reply