cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Assign-To-Do task not completing for days and days

Hi All,

I'm experiencing a huge delay in Assign-To-Do task(Not completing for days and days) in Nintex workflow 2010. Sometimes I get workflow failed to run on Assign-To-Do task.

 

Environment:

  • SharePoint 2010
  • Nintex Workflow 2010
  • Build Version: 2.3.10.0

 

I have a workflow it has assign to do task action and it is autocompleted by updating workflow task items through workflow as shown in the image.

Update item for workflow task and assign to do tasks are lies on parallel actions to achieve expected behavior.

Find the workflow design below:

reject.jpg

When the workflow runs assign to do task creates item in workflow task list and it is completed by update item. But assign to do task action doesn't complete at all.

 

Tried to trouble shoot:

  • Added commit pending actions before and after each actions to make sure all actions are committed and ensure there are no conflicts of batch process before move to next
  • Pointed the workflow to new workflow task list and checked
  • Pointed the workflow to new history list and checked
  • Earlier in DB I had around 80 million records in workflow progress table. Now I have deleted garbage data and reduced up to 10 Million
  • I have checked creating a small workflow to check the function whether assign to do task action is working there or not.
  • Purged all history list for the web application

 

No luck at all. Could you please advise on this to troubleshoot the issue?

Labels: (1)
0 Kudos
Reply
16 Replies
Nintex Employee
Nintex Employee

Re: Assign-To-Do task not completing for days and days

Hi Sivakumar,

is this happening for every workflow or just sometimes?

I'd suggest you restart the Timer service on your farm servers, because that interacts with tasks and lets workflows know when to continue.  It may be in a bad state.

Also, have you checked your SP logs in case there are any messages there around the time you complete the workflow task?

cheers,

Vadim

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

Thanks Vadim for the quick response.

In my web app I have 4 sub sites. The issue is there in all 4 sub sites. And find the logs related the issue below. And if user manually respond to task is completed.

07/30/2014 05:56:36.28 w3wp.exe (0x1A24)                       0x1B0C SharePoint Foundation         Performance                   nask Monitorable An SPRequest object was not disposed before the end of this thread.  To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it.  This object will now be disposed.  Allocation Id: {F3B59A80-D36F-4D2E-AE09-67E0BF4E42A4}  To determine where this object was allocated, set Microsoft.SharePoint.Administration.SPWebService.ContentService.CollectSPRequestAllocationCallStacks = true. c858321e-536a-4fac-8142-10a7f7db13dc

07/30/2014 05:56:36.30 w3wp.exe (0x1A24)                       0x1B0C SharePoint Foundation         Performance                   nask Monitorable An SPRequest object was not disposed before the end of this thread.  To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it.  This object will now be disposed.  Allocation Id: {E4D5E014-46A2-4489-97F9-A23AC3EEB876}  To determine where this object was allocated, set Microsoft.SharePoint.Administration.SPWebService.ContentService.CollectSPRequestAllocationCallStacks = true. c858321e-536a-4fac-8142-10a7f7db13dc

07/30/2014 05:56:36.30 w3wp.exe (0x1A24)                       0x1B0C SharePoint Foundation         Monitoring                     b4ly Medium   Leaving Monitored Scope (Request (POST:server/admin/Lists/Test1/EditForm.aspx?ID=10&ContentTypeId=0x010075B926B84AD14A43B1C494B3CC1DA124&IsDlg=1)). Execution Time=540.378176555959 c858321e-536a-4fac-8142-10a7f7db13dc

07/30/2014 05:56:36.49 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (EnsureListItemsData). Execution Time=18.4976023489019 

07/30/2014 05:56:36.52 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (EnsureListItemsData#1). Execution Time=18.9024024003051 

07/30/2014 05:56:36.72 w3wp.exe (0x1A24)                       0x0AF0 SharePoint Foundation         Monitoring                     nasq Medium   Entering monitored scope (Request (POST:server/admin/Lists/Test1/AllItems.aspx?InitialTabId=Ribbon%2EListItem&VisibilityContext=WSSTabPersistence)) 

07/30/2014 05:56:36.72 w3wp.exe (0x1A24)                       0x0AF0 SharePoint Foundation         Logging Correlation Data       xmnv Medium   Name=Request (POST:server/admin/Lists/Test1/AllItems.aspx?InitialTabId=Ribbon%2EListItem&VisibilityContext=WSSTabPersistence) 17ed4703-145b-4eff-b85f-94a41a3e6616

07/30/2014 05:56:36.75 w3wp.exe (0x1A24)                       0x0AF0 SharePoint Foundation         Logging Correlation Data       xmnv Medium   Site=/ 17ed4703-145b-4eff-b85f-94a41a3e6616

07/30/2014 05:56:36.75 w3wp.exe (0x1A24)                       0x0AF0 SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (PostResolveRequestCacheHandler). Execution Time=21.0845233123204 17ed4703-145b-4eff-b85f-94a41a3e6616

07/30/2014 05:56:37.00 w3wp.exe (0x1A24)                       0x0AF0 SharePoint Foundation         Monitoring                     b4ly Medium   Leaving Monitored Scope (Request (POST:server/admin/Lists/Test1/AllItems.aspx?InitialTabId=Ribbon%2EListItem&VisibilityContext=WSSTabPersistence)). Execution Time=281.010575366422 17ed4703-145b-4eff-b85f-94a41a3e6616

07/30/2014 05:56:37.31 w3wp.exe (0x1A24)                       0x1E80 SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (FireWorkflowPostponedEvent). Execution Time=25.2406381257953 

07/30/2014 05:56:37.33 w3wp.exe (0x1A24)                       0x1E80 SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (Event Receiver (Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c, Microsoft.SharePoint.Workflow.SPWinOEItemEventReceiver)). Execution Time=112.211468217329 

07/30/2014 05:56:37.33 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (Event Receiver (Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c, Microsoft.SharePoint.Workflow.SPWinOEItemEventReceiver)). Execution Time=1128.32887978779 

07/30/2014 05:56:37.39 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     b4ly High     Leaving Monitored Scope (Event Receiver (Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c, Microsoft.SharePoint.Workflow.SPWorkflowAutostartEventReceiver)). Execution Time=62.0877793127339 

07/30/2014 05:56:38.46 OWSTIMER.EXE (0x0D68)                   0x1C34 SharePoint Foundation         Monitoring                     nasq Medium   Entering monitored scope (Timer Job job-timer-locks) 96bee91e-ea83-4786-8441-ca107c7247ae

07/30/2014 05:56:38.55 OWSTIMER.EXE (0x0D68)                   0x1C34 SharePoint Foundation         Monitoring                     b4ly Medium   Leaving Monitored Scope (Timer Job job-timer-locks). Execution Time=92.3533577591565 96bee91e-ea83-4786-8441-ca107c7247ae

07/30/2014 05:56:39.42 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     nasq Medium   Entering monitored scope (Request (GET:server/admin/_layouts/inplview.aspx?List=%7BAF176D5A-83B1-47C4-8575-C2B8B2FF870B%7D&View=%7BAC503656-B268-42EA-A3F1-A29939580BF3%7D&ViewCount=9&ListViewPageUrl=http://server/admin/Lists/Test1/AllItems.aspx&IsXslView=TRUE&Cmd=EcbView&InitialTabId=Ribbon%2EListI...)) 

07/30/2014 05:56:39.42 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Logging Correlation Data       xmnv Medium   Name=Request (GET:server/admin/_layouts/inplview.aspx?List=%7BAF176D5A-83B1-47C4-8575-C2B8B2FF870B%7D&View=%7BAC503656-B268-42EA-A3F1-A29939580BF3%7D&ViewCount=9&ListViewPageUrl=http://server/admin/Lists/Test1/AllItems.aspx&IsXslView=TRUE&Cmd=EcbView&InitialTabId=Ribbon%2EListI...) a3df8e89-5450-4259-98d5-24e3bc867555

07/30/2014 05:56:39.44 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Logging Correlation Data       xmnv Medium   Site=/ a3df8e89-5450-4259-98d5-24e3bc867555

07/30/2014 05:56:39.52 w3wp.exe (0x1A24)                       0x0C6C SharePoint Foundation         Monitoring                     b4ly Medium   Leaving Monitored Scope (Request (GET:server/admin/_layouts/inplview.aspx?List=%7BAF176D5A-83B1-47C4-8575-C2B8B2FF870B%7D&View=%7BAC503656-B268-42EA-A3F1-A29939580BF3%7D&ViewCount=9&ListViewPageUrl=http://server/admin/Lists/Test1/AllItems.aspx&IsXslView=TRUE&Cmd=EcbView&InitialTabId=Ribbon%2EListI...)). Execution Time=83.4597693282247 a3df8e89-5450-4259-98d5-24e3bc867555

07/30/2014 05:56:39.94 OWSTIMER.EXE (0x0D68)                   0x0D24 SharePoint Server Search       Query Processor               e2mv High     EnumerateQueryComponents returned an error after enumerating 0 components. Error returned was 0x80131600. 9c30bb24-b5c9-4aca-ad97-b1aa8602e173

07/30/2014 05:56:39.94 OWSTIMER.EXE (0x0D68)                   0x0D24 SharePoint Server Search       Query Processor               e2tq High       Source: Microsoft.Office.Server.Search   Description: No query components were found for this search application.  [traceerror.cxx:44]  d:\office\source\search\native\ytrip\tripoli\icommand\traceerror.cxx 9c30bb24-b5c9-4aca-ad97-b1aa8602e173

07/30/2014 05:56:39.94 OWSTIMER.EXE (0x0D68)                   0x0D24 SharePoint Server Search       Exceptions                     1hjo Medium   Exception thrown: 0x80131600 (d:\office\source\search\native\ytrip\tripoli\icommand\qpcache.cxx:1444 ip 0x000007FEDEDAD947)   9c30bb24-b5c9-4aca-ad97-b1aa8602e173

07/30/2014 05:56:39.94 OWSTIMER.EXE (0x0D68)                   0x0D24 SharePoint Server Search       Query Processor               0000 Unexpected Exception occurred while triggering query processor cache refresh for application dfccf3cb-89e8-4f9e-a740-850256946094: System.ApplicationException: Error in the application.     at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)     at

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

From the ULS logs, didn't see any related to errors. Maybe you can try to use ULS Viewer to limit those entries only by filtering Nintex Workflow 2010 as Product column or Legacy Workflow Infrastructure as Category column, then export out the log to us.

Or is it possible we can have your exported NWF? It will be easier for us to troubleshoot.

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

I have tried to use ULS Viewer to limit those entries only by filtering Nintex Workflow 2010 as Product column or Legacy Workflow Infrastructure as Category column.

But I could not find any entries related to those. I don't have option to attach my workflow file here.

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

Maybe you need to try to turn out Verbose logging for Nintex Workflow category, by :

Navigate to CA > Monitoring > Configure diagnostic logging (http://{CentralAdminUrl}/_admin/metrics.aspx)

Select Nintex Workflow Category > Change to Verbose/Verbose

For attach file, you can edit your reply, then you can see an Attach hyperlink on the botton right box on the page.

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

Please find the attached workflow.@Chit Siang Chew

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

Have you tried separating the parallel action. The wait for function is like a pause so it can could stop the Assign-To-Task from kicking off.

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

Can't separate parallel actions since assign task and update the related task item can't be in a sequence. Wait for item update action is needed to get the users response. So I believe there is nothing wrong with the design of the workflow. Can somebody help to troubleshoot?

0 Kudos
Reply
Not applicable

Re: Assign-To-Do task not completing for days and days

By importing your exported "simple" version of workflow, it looks ok to me from my side. I using 2.3.13.0

AssignToDoTask.png

Do you have very big workflow?

Do you use any event receiver onto the Workflow Task?

 

The best to troubleshoot I guess, try to turn on Verbose Logging, replicate the issue, then export the ULS logs around that time and send to us.

0 Kudos
Reply