MrSkold
Scholar

"Set item permissions"-action not working

Hi,

 

I have this SharePoint list to which 'Everyone' have 'Contribute' permissions. In addition, my 'Advanced list settings' are set to the following:

2020-03-06 08_58_57-Window.png

 

 

 

 

 

The list contains a number of workflows and in the last very workflow that runs for each item I want to (temporarily) provide edit permissions to a single user to allow this user to attach a file to the item. Once the file has been attached I want the item to re-inherit the permissions from its parent, to avoid the list being filled with items with unique permissions.

 

I have played around with the 'Set item permissions' action in my workflow and it runs without any errors and when I check whom the item is 'Shared with' it says it has unique permissions and displays the user and the assigned permissions (as if everything was in order). However, when the user edits the item and tries to save it an error message appears saying that the user lacks the required permissions... Does anyone know what I am doing wrong here?

 

I have tried assigning different permissions levels and even with the 'Full Contol' permission the user is unable to edit the item.

0 Kudos
Reply
4 Replies
Michel
Contributor

Re: "Set item permissions"-action not working

Hi,

So, if I understand you correctly, you notice that the users are receiving the correct permissions on the item when looking at the List Item Permissions? Even though the user has the correct permissions, the Item level permissions set via the List Settings overrule the permissions set per list item. The item(s) that a user is editing, are those created by the user as well?

Kind regards,
Michel
0 Kudos
Reply
MrSkold
Scholar

Re: "Set item permissions"-action not working

Hi Michel,

 

Exactly, although the item permissions show that the user has 'Full Control' it is like the permissions defined in the list settings over-rules them. No, the creator and editor in this scenario are two different users.

 

Thanks in advance,

Martin

0 Kudos
Reply
Michel
Contributor

Re: "Set item permissions"-action not working

Hi Martin,

That last part might explain it then. As configured in the 'Advanced List Settings', you configured that only the creators are able to edit their own items.

So, even though another user has Full Control permissions on the list item (and is not an owner of the site), he/she is still unable to edit the permissions.

To confirm, can you set the configuration to 'Create and edit all items'?
0 Kudos
Reply
Michel
Contributor

Re: "Set item permissions"-action not working

Did you managed to resolved the issue?
0 Kudos
Reply