cmikhaiel_e
Scout

Re: Workflow doesn't start automatically

Jump to solution

I'm having the same issue on a SharePoint 2010. The workflow isn't started by a system account or pro grammatically. It is setup to start upon creation by a regular user. The items sits for days unnoticed, and the workflow never starts on its own. I've even setup a secondary workflow to start after 5 minutes just in case the first one didn't start. If SharePoint has decided that it doesn't want to start a workflow on an item, it just doesn't start any of the workflows on that item.. 

I've also changed the workflow timer to be 1 min instead of 5 minutes, but that doesn't help as I understand that this will only assist to make the workflows with State machines run faster..

any idea? 

0 Kudos
Reply
vadim_tabakman
Nintex Employee
Nintex Employee

Re: Workflow doesn't start automatically

Jump to solution

Hi Christine,

check your SP logs for "Workflow Infrastructure" errors around the time you created the item.  Hopefully there is something there that could suggest why SP isn't starting the workflow.

Vadim

0 Kudos
Reply
cjones69
Scholar

Re: Workflow doesn't start automatically

Jump to solution

Were you able to find a way to start the workflow when email was received? I need this functionality, but apparently it is not possible without customization.

0 Kudos
Reply
michuk
Scout

Re: Workflow doesn't start automatically

Jump to solution

@c_heindel wrote:

Hi Anderson Sarria,

 

Workflows do not start automatically if the item has been created by "System Account" (programmatically or via email). Can you please check if that is the case for your workflows that won't start?


I have items created by the system, so how do you deal with this?

0 Kudos
Reply
ERefat
Scholar

Re: Workflow doesn't start automatically

Jump to solution

I have the same issue for Nintex O365 workflow everything was going smooth and nice tell yesterday

the all process suddeny stopped from running automatically based on condition the process usally start automaticully for modify or created today user reported that his process wont start

any clearificationfor sharepoint online Office 365

0 Kudos
Reply
aweber
Rookie

Re: Workflow doesn't start automatically

Jump to solution

Hi,

 

Any news on this? Same thing happened, the workflows started automatically and they suddenly don't. We haven't changed anything. 

 

They start automatically when adding a document in the library manually, but not when we add it from another source.

 

Thank you

0 Kudos
Reply