shirane
Canvas Initiate

Update Item Permissions not working when other users run workflow

Hi,
We have Sharepoint online and plan to start using it soon.
One of the first uses of the company will be the Performance Review process.
I've created a Sharepoint team site (currently a private site with me as the owner with full control, and my teammates as members with contribute permissions).
I created a list, and a Nintex form and Nintex worfklow.
The default permissions to the list are: Owners (Full Control), Members (Contribute), Visitors (Read).
Each person should be able to create a list item via the form, and after he/she submits the form, the permissions should change. All permissions should be removed and then added as following: Site owners (full control), HR team (read, for the test I put me and another team member as HR personnel), the employee (read), the employee's managers (read) - which are in the members group. 
The workflow has a few steps of Updating Item Permissions (according to the previous explanation).
I've created a Shared site and user administration connection (to active directory) with my admin credentials.
I broke the inheritence of the permissions, and the first Update Item Permissions step removes the previous item permissions (and the other update item permissions steps don't remove).
At the end of the workflow, an email is sent to the direct manager.
I managed to run the workflow well from my user, but when I run it from my other teammembers' accounts, the workflow stops working after the first Update Item Permissions step (it only gives the owner full control, and then it stops).
I also tried using the "Action Set" with the eleviate permissions box checked, on the whole workflow, and tried also on the specific steps that aren't working, and it didn't help in neither case.
I'd appreciate any help with this.
Thanks!
Shiran
0 Kudos
Reply
2 Replies
v-tmasenko
Design Canvas Artiste

Re: Update Item Permissions not working when other users run workflow

Are you using a shared or personal connection in your Office 365 Update Item Permissions action?
- If so then the connection type needs to be "SharePoint Online: Update item permissions (OAuth2)
- "Users with access" needs to identify the users who can use the shared connection
- Does "Available in" scope selected:
--"tenant"
--"site only" for the site that contains the list and corresponding workflow
--"this site collection" that matches the specific list within the target site
- When editing the shared connection the "Workflow usage" section will identify all workflow names & location with the number of Actions (occurrences) that reference it.
0 Kudos
Reply
shirane
Canvas Initiate

Re: Update Item Permissions not working when other users run workflow

shared, wrote in my original post. 🙂

After many tries, I succeeded to have it working from other users by actually changing the order of the Set Item Permissions boxes.

First the user, then all the others.

But now I have another issue, maybe you can help -

The whole workflow takes about 3-4 minutes to complete, while the first permissions grant takes a little less than a minute. At that time-frame, anyone in the company can access items created in the list until the permissions are granted successfully. How can I avoid this from happening or how can I have the workflow work faster?

0 Kudos
Reply