SPFA
Nintex Newbie

Unable to retract workflow features

Hey there, I'm running in to an annoying issue. We have a SharePoint 2013 Farm with Nintex Workflow 2013 installed. We are running in to the issue listed here: 

https://community.nintex.com/t5/Nintex-for-SharePoint/WorkflowDesigner-aspx-not-loading-correctly/td....

 

I tried the proposed solution at the bottom or that post, but when I get to the point where I have to retract all the solutions, I am able to retrac the "nintexworkflow2013.wsp" and "nintexworkflow2013enterprisefeatures.wsp" from all web applications except from the central administration web application. It tesll me "Status = Retracting" but then it finishes and the status still reads "Deployed". Thus I cannot continue to remove the solutions so I can re-install. I have tried force removing the solutions without retracting using the following command:

Uninstall-SPSolution -Identity mySolution.wsp -allwebapplications
Remove-SPSolution -identity mySolution.wsp -force

But the result is not good because when I try to re-install Nintex, the "nintexforms2013core.wsp" never deploys no matter what I do, and the two solutions mentioned in the begining ("nintexworkflow2013.wsp" and "nintexworkflow2013enterprisefeatures.wsp") never install. 

 

I have tried the suggested fixes/workarounds in the follwoing resources:

 

But my issue is that I get stuck trying to retract these solutions "nintexworkflow2013.wsp" and "nintexworkflow2013enterprisefeatures.wsp".

That being said, is there a very detailed/specific nintex document/procedure on how to appropriately remove nintex workflow to perform a reinstall, or is it just a corruption in my farm that is causing these solutions not to be able to retract from the central administration web application?

Or, are there any other fixes for correcting the issue with the workflow Desinger without having to uninstall/reinstall?

 

Thank you , I have spent 16hrs trying to troubleshoot this with no luck.

 

SPFA - dm

 

0 Kudos
Reply
1 Reply
SPFA
Nintex Newbie

Re: Unable to retract workflow features

So, Nintex fixed this for me. Thank you Nintex Support, won't share the Tech Name for obvious reasons but he did a great Job. 


Sort Story:

1. Retract the solutions as described in the documentation

   a. Nintex enterprise features backwards compatibility 

   b. Nintex workflow 2013 backwards compatibility

   c. Nintex enterprise features

   d. Nintex workflow 2013

   e. Nintex workflow core solutions

NOTE: now, here is the catch! - Nintex workflow 2013 and Enterprise features were retracting from all web apps except central admin, however we kept going in order and retracting the other solutions.

 

2. Once you retract all solutions, Re-Deploy the solutions in order (go backwards from the list in step 1 above)

 

3. After this my workflow designer started working correctly.

 

Lessons learned:

1. Even if the solutions don't retract from central admin, keep going in order. Don't try to force remove the solutions, it will only further break your farm

 

2. DO EVERYTHING THE NINTEX TECH TELLS YOU TO DO. I had tried most everything he told me to try, I could have gotten difficult and said so. However I just shut up and listened and they got my issue resolved. My problem was I was getting caugh up with the solutions not retracting from Central Administration web app and I was force removing stuff and breaking my solution..

 

EPILOGUE: Thank you Nintex Support!

0 Kudos
Reply