dbakergsy
Forms Fledgling

Task attachments not appearing on list item

Hi everyone, I have an issue where I've created a Nintex form with attachments. However, when a user attaches documents they remain within the task and don't transfer to the list item the task is running on.

I can see lots of posts about resolving a similar issue where you need to see list item attachments in the form but I need the task attachments to appear on the list item!

I would have thought this would be a pretty standard thing to do but apparently not! 🙂

Thanks for your help.

0 Kudos
Reply
3 Replies
ncocchiara_77
Canvas Initiate

Re: Task attachments not appearing on list item

I am having the same problem!  I came across a post that helped but the links displayed in my form are not clickable nor are they pretty!  I am still working on it.  Maybe you will have better luck!  Here it is: Add List Item Attachments to Task Form using Nintex Workflow and Forms – Nicole Vesser (nicoleprestb...

 

0 Kudos
Reply
dbakergsy
Forms Fledgling

Re: Task attachments not appearing on list item

Thanks @ncocchiara_77 , I'm actually trying to do it the other way around. i.e. getting the task items to attach to the list item. Many thanks for the reply though - I'm sure it will come in handy too!

0 Kudos
Reply
kunalpatel
Automation Master
Automation Master

Re: Task attachments not appearing on list item

@dbakergsy I think you will have to use Web Service call and Query XML to get the attachments and using Web Request you'll have to attach in the list item. I've done the other way around but not from Task to list. The easy approach will be to provide the Edit Mode link to your list item in task notification and instruct the task respondent to first attach in list item and then completes the task.

0 Kudos
Reply