JagadeeshB
Design Dabbler

Not able to log the value of the lookup field

Jump to solution

Hi, 

I am trying to log the value of the lookup field to my workflow history but it is not working.

 

Ex: I have a studentList with StudentID, StudentName columns and now there is the second list Report which contains lookup fields StudentID, StudentName, and Marks.

 

Now when I am trying to log the value of StudentID in Report List it is not showing any value.

Can anyone help me to resolve this?

 

Thanks,

Jagadeesh

 

 

0 Kudos
Reply
6 Replies
emha
Automation Master
Automation Master

Re: Not able to log the value of the lookup field

Jump to solution

can  you post a screenshot how do you do that?

are you sure a value is populated in a list field?

what are the circumstanes when you want to get value written to log?

 

0 Kudos
Reply
JagadeeshB
Design Dabbler

Re: Not able to log the value of the lookup field

Jump to solution

Hi emha,

Below are the screens of the original list, look up list and workflow and log history

Look Up listLook Up listworkflowworkflowList with lookup columnList with lookup columnimage.png

 

0 Kudos
Reply
emha
Automation Master
Automation Master

Re: Not able to log the value of the lookup field

Jump to solution

was the lookup field already populated before you started workflow? or did you populate it withi workflow?

or do you change it's value within the workflow?

 

 

is "Document status" field your custom field or have you reused some OOTB provided one? 

I wonder whether the name is not reserved for some internal use and whether that doesn't cause problems. can you maybe try with a different name (create new field)?

 

 

0 Kudos
Reply
JagadeeshB
Design Dabbler

Re: Not able to log the value of the lookup field

Jump to solution

I triggered the workflow once the item is created.

It is a custom field.

I already tried it by creating a new field with a different name but no result that way also

 

0 Kudos
Reply
emha
Automation Master
Automation Master

Re: Not able to log the value of the lookup field

Jump to solution

so, is it so that when item is created the field is empty, then you do some logic and set the field to 'Approved' and tries to log its value right away?

 

if it is so, then that would explain it - the value is not yet effectivelly to the list, so you can't see it.

View solution in original post

0 Kudos
Reply
JagadeeshB
Design Dabbler

Re: Not able to log the value of the lookup field

Jump to solution
Thank you emha.You are correct when the item is created it is empty so since workflow is triggered on the creation of item we are not able to see it.
0 Kudos
Reply