Kaushik_Mehta
Novice

Nintex Workflow Not Triggering When Item Created using CSOM

Jump to solution

Hello All,

 

We are facing strange issue where workflow is not getting trigger when item is created / modified using CSOM,

So we have a workflow (WF1) on List (L1) which is set on running when item is created or modified. 

Currently we have a .net portal and public user submit the data from this .net portal & using CSOM we create records in List (L1) using account (Account1 - Not System Admin). 

We can see the records getting created in List (L1) with account (Account1), But the workflow is not getting triggered. But if I login with the same account (Account1) in SharePoint 2019 on-premise and create item or modify the workflow is getting trigger. 

 

Need help on why the workflow is not getting trigger when item is created using CSOM.

0 Kudos
Reply
1 Reply
sumitdeJedi
Nintex Employee
Nintex Employee

Re: Nintex Workflow Not Triggering When Item Created using CSOM

Jump to solution

Hi @Kaushik_Mehta 

 

Nintex workflows for Sharepoint on-prem use the standard Sharepoint list event receivers to start a Nintex/Sharepoint workflow when an item is created/modified.

 

You're most likely going to see the same behaviour if an SPD or Out of box Sharepoint Approval Workflow

 

A possible solution is to add a conditional start to the Nintex workflow, with a condition that is always true i.e. ID > 0.

 

This would then use Nintex List event receivers instead of the default Sharepoint ones. Beyond that, you may want to use a site scheduled workflow that runs every hour and processes newly created items.

 

I hope that helps,

 

Sumit

View solution in original post

Manage approvals in SharePoint document libraries using the built-in Approvals workflow: http://www.kalmstrom.com/Tips/SharePoint-Workflows/Approvals-with-Bu...
0 Kudos
Reply