Nintex Newbie

Nintex Form List Lookup Displays ID Instead of Value

I have a Nintex form and a list lookup field that queries a Site list. The Site list has all the sites for our organization listed in the Title column:






The problem is that the form displays the ID. When I am filling out the form, it shows me the value (AL). When I select the value, it still displays. When I save the form, it displays the item ID in the list (1). So instead of a list with everyone's site locations, I get a list with ID numbers. I have used the List Lookup feature before and this is the first time I have encountered this. Any ideas why it is displaying the ID? It's a direct connection to my Title column.

Note: I created a new text column in my existing list and copied the site data into that. I then connected the List Lookup to the new text column and it still displayed the ID. I also created a new Test list and went through everything in that list and the same result. My List Lookup is displaying the ID regardless of the source list or source column.

The problem seems to be in the form. I found this post:

I just can't understand why it has worked before, but doesn't work now.

EDIT: Because time is of the essence, I cheated and used a calculated field to pull the Title field and populate my list with that. It doesn't solve the problem, but it is a workaround.

1 Reply
Nintex Observer

Re: Nintex Form List Lookup Displays ID Instead of Value

Just adding this for any future people with the same issue.

In the form control settings, there is a section to choose 'connect ID to column' or 'connect text to column'. Selecting 'text to column' rather than ID should solve your problem.

0 Kudos