Not applicable

Inline functions stops to work when nested

See updates to this post at the bottom




Nintex Forms 2013 on prem.


First off, I haven't got a guide to reproduce this problem, but I have experienced it twice now, resulting in having to reset the form I'm working on to get it to work again.


I experience that nested inline functions stops to work. Here is an example of the latest occurrence:


The default value is an IsMemeberOfGroup-function within an if-function.

I have seen this work, in the very same control, returning FALSE or SHOWALL. But suddenly, while working on another control, unrelated to this one, the results starts to be this:


As you can see, the first "False" is the result of the IsMemeberOfGroup-function. But the if-function is just not being executed as it should be.


I have experienced this kind of behavior twice now. The only correlations between these two times (as far as I can think off) is:

  • Nested inline functions.
  • Did not do work on the controls where it failed.
  • All controls with nested inline functions started to fail at the same time.
  • It happens both in preview and if I publish the form.


I have tried a couple of things, but because all nested inline functions started to fail at the same time in the form, I think it's related to the form as a whole. I have tried reloading the form, restarting the browser and restarted the computer. Deleting and recreating the controls does not give anything either. Only a reset of the form seems to help.


I have exported the form. If any Nintex employee wants to see it, they can contact me.


Any ideas?


Kind regards,



EDIT (19/2 13:24): Update: It seems that deleting the last control I was working on when it happened, makes all the other controls work again. Still no explanation on why it fails.

1 Reply

Re: Inline functions stops to work when nested

I am using Nintex Form Office 365 . I am facing the same problem. Inline function doesnot work even if it is not nested.

Did you got any solution ?

0 Kudos