kls987
Nintex Observer

Hyperlink not formatting correctly in Flexitask notifications

I'm using Nintex 2013 with SharePoint 2013 On Prem. I don't know what service pack we have installed, as I'm not the farm administrator.

 

I am trying to have a link to the item display in a Flexitask notification, and having nothing but problems. I frequently have the problem where Title displays "Title" (without quotes) instead of the actual item title. If i've inserted the title as the Text to Display in a link, the link works, but "Title" is displayed. I thought I'd come up with a workaround by using a variable, varReadItemLink, that is set by Build string, {Common:ContextItemUrl}, {ItemProperty:Title}. When I did this, the email showed the link as https://.... [as a link], Actual Item Title [not linked]. This is messy.

 

So then I created a field on my list called ReadItemLink, set as a hyperlink field, and used Set Field to set ReadItemLink to equal varReadItemLink. When i did this, the email showed the link as http://.... [as a link]. The item title was missing completely.

 

I have checked my formatting of the string and it has the correct placement of comma and space between the properties. I know this formatting works as I've used it on other lists and in workflows (setting the field via workflow), just not in notification emails. If I didn't have the issue of Title displaying as "Title" or "Context Item URL," this wouldn't be an issue, but it is, and none of my workarounds seem to work.

 

Any other ideas for possible workarounds?

0 Kudos
Reply
1 Reply
eharris04
Workflow Hero

Re: Hyperlink not formatting correctly in Flexitask notifications

In the flexi-task you should be able to directly reference the link to the items parent for that task. If something is not working here, can you share a screenshot of your form and the flexitask configuration?

0 Kudos
Reply