Not applicable

How to schedule site workflow to run following my local time and not system time?

I'm having a problem regarding scheduling workflow. It doesn't start immediately on the the time I set.  Sometimes it starts after a few minutes and sometimes after a few hours. I tried setting the time following the US time and it ran. But if I set the start time according to my local time, it doesn't.

Would there be any way where the workflow would start running according to my local time?

Thank you so much!

0 Kudos
Reply
1 Reply
Not applicable

Re: How to schedule site workflow to run following my local time and not system time?

Hi Aerielle,  As your scheduled workflows start a few minutes late up to hours late this is not a time zone issue.  It sounds like you are having some issues with the SharePoint Timer Service and performance. The Nintex Workflow Scheduler works in that service.  As a first step to fixing this, please try restarting the SharePoint Timer service on all servers in the farm where you can find it. I expect that will fix it up fairly quickly.  However, it's quite possible that it will get backed up again, in which case we'll need to dig deeper and look at the database.  If it does get backed up again, please read this document, as it explains what to do.  "Test 1" will be of particular importance and will give a very good idea of any workflow instances that might need to be terminated then purged to improve performance:  https://community.nintex.com/docs/DOC-1306  The workflow timer service by default runs every 5 minutes and the scheduler wakes up in this service.  This means that there is always a possibility of scheduled workflows starting 5 minutes later than scheduled as the schedule will run the next time the timer service runs.

0 Kudos
Reply