FlorianZ17
Nintex Newbie

Hide Disable Rule for more for more than one answer not working on Lookup Field

Jump to solution

Hello everyone,

 

I have a question about a hide funcation regarding a Lookup Field.

I build the following formular:

not(equals(parseLookup(Projekttyp),"Relativity"))

 

How can I add a second answer option? 

So that ist shows the field only if I select "Relativity" or "Brainspace".

 

Kind Regards

Florian

0 Kudos
Reply
3 Replies
Lübbe
Nintex Newbie

Re: Hide Disable Rule for more for more than one answer not working on Lookup Field

Jump to solution

Hi Florian,

 

I would recommend to make use of a Form Variables: Just create a new one, for example with the name strMyFormVar, and assign to this variable only the formula parseLookup(Projekttyp).

 

After this you can change your hiding-rule to:

not(or((strMyFormVar == "Relativity"), (strMyFormVar == "Brainspace")))

 

or alternativly, if "==" doesn't work:

not(or(equals(strMyFormVar,"Relativity"), equals(strMyFormVar,"Brainspace")))

 

Hope that helps.

 

View solution in original post

Tags (3)
Reply
FlorianZ17
Nintex Newbie

Re: Hide Disable Rule for more for more than one answer not working on Lookup Field

Jump to solution

Thank you very much for your help. It works perfect. 🙂

0 Kudos
Reply
ethurber
Nintex Newbie

Re: Hide Disable Rule for more for more than one answer not working on Lookup Field

Jump to solution
I'm going to add a quick note here because I've seen it so often and since I discovered the option it has saved me countless hours developing rules. You can use standard Boolean syntax in your forms.

!(strMyFormVar == "Relativity" || strMyformVar == "Brainspace")

|| = OR; && = AND. you can control order of operation with parentheses.
Reply