Canvas Initiate

Fields missing in Create Item - Nintex For SharePoint 2013

When I use the Create item action in Nintex Workflow 2013. For some of my content types, I am not able to find some of my fields. When I click the Field dropdown, some fields do not show up.

If I do the same thing using the Create item in another site, pick the current site and the same list and content type. I do see the field show up in the list.

First, I wonder if this is a valid workaround. I will be copying this workflow to a production environment and I don't want to have to go through all my workflows to make sure that I change this particular action because it will be creating an item in the wrong site. 

I have tried setting the Field to Required. I deleted and added the field to the content type again. I also tried adding another field to the content type and it did appear in the dropdown almost immediately. Problem is, after I removed it from the content type, it continues to show up.

Is there a way to forcefully update the content type in workflow? Is there a sync content type method that I could try? I was thinking about exporting the Workflow and editing the XML, but I'm sure that is not a supported method.


0 Kudos