ganesh_lathi
Novice

Error executing inline (fn-Trim) function.

Jump to solution

I am getting below error,

Failed to send notification. Error executing inline (fn-Trim) function. Check that the correct arguments have been passed to the function

This is within the notification subject. most of the time it works but sometime it fails. not sure what is the exact reason.

Any idea ?

Reply
4 Replies
fhunth
Scout

Re: Error executing inline (fn-Trim) function.

Jump to solution

Try adding a log to history list , the value used inside the function

0 Kudos
Reply
philipplucas
Scout

Re: Error executing inline (fn-Trim) function.

Jump to solution

Hi Ganesh,

can you please provide a screenshot or some further explanation about what parameters you have put into the fn-trim function?

If it only fails sometimes, the reason could be that you provided a variable as parameter that may be empty or invalid in some cases.

Regards

Philipp

0 Kudos
Reply
ganesh_lathi
Novice

Re: Error executing inline (fn-Trim) function.

Jump to solution

Hey Philipp & Fernando, thank you very much for taking time to respond to my question.

I was able to figure out the issue.

I had to put {TextStart} and {TextEnd} tags around my string variable/ column.

At the end it looks like this..

fn-Trim({TextStart}Title{TextEnd})

In some cases, Title was having "," in between.

Ganesh

View solution in original post

Reply
LoriMeyer-40
Scholar

Re: Error executing inline (fn-Trim) function.

Jump to solution
Please make sure {} is enclosing your ItemProperty:Title when you insert a reference or else it doesn't return the value but the passed parameter only.

I wonder if putting an value in with {[0-100]} with cause the fn-Trim to only include the values assigned within the string/variable column.

Any thoughts?
Lori
0 Kudos
Reply