yvette
Nintex Newbie

Conditional start not working for Modified by specific user

Hello everybody,

I set up a conditional start for a workflow, to not start on Modified when the item property ‘Modified By’ doet not equal our Workflow service account.

WF Start condition.PNG

This way, we can edit items without the workflow running again. At least, that's the idea. But we find with this set up the condition is ignored and the workflow will start anyway. 

Is this a bug or is this condition not possible?

I've been looking at release notes since we are on quite an older version of Nintex 2013 but have not found anything.

Tags (1)
0 Kudos
Reply
2 Replies
MegaJerk
Automation Master
Automation Master

Re: Conditional start not working for Modified by specific user

I think that the logic might just be a bit backwards.

You're setting the Conditional To Start when the Item is Modified, 

Then you're saying that the condition is: 

When the [Modified By] Is NOT Equal to Nintex WerkstroomService

 

That means that it WILL start when the Modified By = Anyone Else!

 

I think that if you just changed it so that it is set to Equal To (gelijk aan), then it should be alright and work the way that you'd like it to!

0 Kudos
Reply
yvette
Nintex Newbie

Re: Conditional start not working for Modified by specific user

Thanks for your reply! This is exactly what needs to happen: 

That means that it WILL start when the Modified By = Anyone Else!

 

However the worfklow also starts when Modified By = Nintex Werkstroomservice. That shouldn't happen according to my logic.

 

I selected the account name from the Adress Book. I can't figure this out exactly but it must have something to do with migrating from NTLM to ADFS authentication a while back.

 

Just wanted to check here that a conditional start with a referenced account is possible and it is not a bug.

 

0 Kudos
Reply