Rabaga
Novice

Call Web Service (get user collection from group): Error 401 Unauthorized

Hello,

 

We have 5 nintex WFs where most of them (4/5) have the Call Web Service action (get user collection from group) under the same credentials/configuration. However, we get error 401 just in one of the workflows.

 

The weird thing is, when using the "Test Connection" button in the action returns a "OK" message, and the "Refresh" button in the action returns the list of available web services to populate and be selected. It is only when the actual call is attempted that it returns with a (401) Unauthorized response.

 

Also, we have tried opening the web service on the server. The behaviour is exactly the same as on the desktop. We can browse to the web service definition but any time we try to access it via workflow we got unauthorised.

 

Finally, we tried disabling Loopbackcheck (in both servers) and configuring a BackConnectionHostNames entry in the registry App Server. However, the problem persists.

 

Configuration:

 

  • Enviroment: Sharepoint Server 2016 on Premise within minRole tipology (1 Application with Search server and 1 Front-end with Distributed Cache server).
  • Nintex version: 4.5.2.0
  • Each SharePoint group has the same configuration: SharePoint group administration owner and everyone can see who is inside. (Before, we had an farm administrator as an owner)
  • The Call Web Service action is executed with farm administrator.

 

Any help to solve this "inconsistency"?

 

Resource links:

 

0 Kudos
Reply