Nausheen_H
Canvas Initiate

Attachment not appearing on the nintex form after file has been attached

I have a nintex form on SharePoint Online. It has got a mandatory attachment control which is also the default attachment control. User attaches the attachment. But when the form is opened later, the attachment dissapears. Is there a way we can solve this issue? We use classic nintex forms.

 

0 Kudos
Reply
9 Replies
SimonMuntz
Nintex Employee
Nintex Employee

Re: Attachment not appearing on the nintex form after file has been attached

Hi,

When you look at the item in SharePoint does it have an attachment?
The issue is either the attachment is not being saved to the list or the attachment is not being shown on the form. Each issue having different troubleshooting steps.
0 Kudos
Reply
Nausheen_H
Canvas Initiate

Re: Attachment not appearing on the nintex form after file has been attached

Thanks Simon! The attachment is a mandatory field. We have validation for it. The user will not be able to submit the form without it. So it probably is an issue on attachment not being shown on the form.
0 Kudos
Reply
SimonMuntz
Nintex Employee
Nintex Employee

Re: Attachment not appearing on the nintex form after file has been attached

I get what you are saying but I suggest still checking to make sure the attachment is actually on the item in the list.
0 Kudos
Reply
Nausheen_H
Canvas Initiate

Re: Attachment not appearing on the nintex form after file has been attached

The other thing is we have multiple attachment on the form. The other attachment is coming up and as a result of which the attachment column in the view shows there is an attachment for the column. Is there a way I could check if this specific attachment has come across?
0 Kudos
Reply
SimonMuntz
Nintex Employee
Nintex Employee

Re: Attachment not appearing on the nintex form after file has been attached

Delete the Nintex form after exporting it and check using a SharePoint form to see all the attachments on the item.
You can import it back in when your finished checking.
0 Kudos
Reply
Nausheen_H
Canvas Initiate

Re: Attachment not appearing on the nintex form after file has been attached

Hi Simon, I deleted the Nintex form and tried opening the default form. Unfortunately my default view form was not coming up. I tried doing a rest call to get the attachments. The rest call could fetch the attachment which is visible on the Nintex form. The other missing attachment did not come up. I guess the attachment is not getting saved to the list. I tried editing the same item. I submitted tried submitting it without attachment. However, I am unable to save it. Please advice what may be the root cause of the attachments not getting saved to the list.
0 Kudos
Reply
Nausheen_H
Canvas Initiate

Re: Attachment not appearing on the nintex form after file has been attached

@SimonMuntz - please advice.

0 Kudos
Reply
SimonMuntz
Nintex Employee
Nintex Employee

Re: Attachment not appearing on the nintex form after file has been attached

Hi,

Anything I advise from here on would be pure speculation.
I suggest contacting Nintex support for a thorough investigation.
support@nintex.com

It sounds like there is a bigger underlying problem if you cannot open the item after removing the form.
Can you submit all the attachments with the default Sharepoint form?
0 Kudos
Reply
Nausheen_H
Canvas Initiate

Re: Attachment not appearing on the nintex form after file has been attached

Thanks. Will give it a try and share the results

0 Kudos
Reply