cancel
Showing results for 
Search instead for 
Did you mean: 
SamSysum
Nintex Employee
Nintex Employee

ALERT: Error creating DocGen Packages for new installs

We have determined that there is an issue creating new DocGen Packages using the DocGen Package Wizard for customers who have installed Nintex DocGen Drawloop for the first time, upgrades we have confirmed are not impacted. The root cause of the issue appears to due to a configuration issue that is not being set for new installs, we believe this to be caused by a change from Salesforce and are working with Salesforce Support to determine steps to resolve the problem.

 

UPDATE: We have confirmed with Salesforce that the root cause of the issue is a bug on their side, though it may not impact all Salesforce instances. Salesforce has developed a fix this issue with the plans to roll it out in the Spring '20 release. For updates on the Salesforce fix, you can review and follow the Known Issue here: https://success.salesforce.com/issues_view?Id=a1p3A0000003gB1

 

There are currently two (2) workarounds until we get some resolution from Salesforce:

Use the new Lightning Experience DocGen Package Designer (LEDD) in Lightning

Creating DocGen Packages in LEDD has been successful. Once the DocGen Package is created, you can continue with confiuring your DocGen Package in Lightning, or switch back to Classic for Classic DocGen Package Management. 

 

See Enable the Lightning Experience DocGen Designer  for instructions on how to enabled LEDD if you have not done so already. 

 

Set Default Record Type for applicable Profiles

This option involves setting the default Record Type of the DocGen Package object to Opportunity

  1. Go to Setup > Manage Users -> Profiles -> [Profile]
  2. Scroll to “Custom Record Type Settings” -> DocGen Packages 
  3. Click the Edit link 
  4. Set “Opportunity” as the Default Record Type
  5. Click Save

Once the defualt record type has been created, DocGen Package creating in Salesforce Classic will once again be successful. 

0 Kudos
Reply