cancel
Showing results for 
Search instead for 
Did you mean: 
Nintex Newbie

jquery.SPServices CAML query no working on Nintex form

I trying to call a jquery.SPServices CAML query, It work on normal Sharepoint form, but fail on Nintex Form.

This is what have i done on the Nintex form,

Add the JavaScript reference library to the Custom JavaScript Includes (under form settings)

https://ajax.googleapis.com/ajax/libs/jquery/1.11.2/jquery.min.js 

https://mySharepointSite/SiteAssets/jquery.SPServices-0.7.2.min.js
https://mySharepointSite/SiteAssets/SupplierRegister_OpenAccount.js

https://mySharepointSite/SiteAssets/SupplierRegister_OpenAccount.js

 Where executing, on line 12, its always return "parserror".

Please help. Thank you.

Further drill down. I found this on the response message.

I believe its because the Nintex Form Iframe cause this problem.......

Tags (2)
Reply
2 Replies
Automation Master
Automation Master

Re: jquery.SPServices CAML query no working on Nintex form

Hi,

I think that the issue is that every O365 app runs in a different web site (if your tenant is https://contoso.sharepoint.com, each app will run in something like https://contoso-<guid>.sharepoint.com)

so, when SPServices try to do a call on /_vti_bin/lists.asmx, it does it in the current context, so the call goes to https://contoso-<guid>.sharepoint.com/_vti_bin/lists.asmx that doesn't exist..honestly, unless you change spservices code to strip the guid part of the base url, I don't think it will work with Nintex or with any other app, sorry...

Giacomo

Reply
Nintex Newbie

Re: jquery.SPServices CAML query no working on Nintex form

It looks like SPService is no longer working for Nintex forms in O365. Does Nintex provide any solution for that?

0 Kudos
Reply