cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

Hello,

When we try to navigate throught a Iphone to a form that have a phone layout published, we recieve a message "Enable cookies on your browser to use the form"...

We have made sure that cookies is enabled always throught the Safari settings on the phone, no success..

We tried also by removing all history data.

We tried with rebooting the iphone.

We tried download Chrome browser and tried throught that..

No success...

What kind of authentication is used by Nintex? Since most of the other microsoft integrated cloudbased apps works fine throught Iphone but not a Nintex Form?!



Tags (1)
Reply
10 Replies
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

Hi,

I am just guessing that you are trying to access Nintex Forms directly through your browser in iPhone. Now in that case, then authentication is being handled by SharePoint.

Did you try to use Nintex Mobile app? It will give you all your forms published with Mobile layout.

Regards

Shirin

Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

Rammtin Avar‌ have you resolved your issue? Is Shirin's answer helpful thus you could mark it as "correct"?

Regards,

Tomasz

0 Kudos
Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

I have a client impacted by this.  They are able to browse SharePoint just fine in both Safari and Chrome, it isn't until they try and launch the form that they are seeing the "enable cookies" message.  Currently, they are trying to keep it in the browser versus using the mobile application which IIRC does not support the MMD fields in the form.  

0 Kudos
Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

I can confirm the same behavior as Mike. Using safari on an iPhone in non-private mode will not display any Nintex forms in the browser. The form I tried to go to was a list form using responsive mode.

Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

Thanks Andrew Glasser‌, not what I wanted to hear.  

0 Kudos
Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

Hi,

Based on the discussion with forms team, There is a support ticket for that and it's being looked at.

0 Kudos
Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

We did some further digging with Nintex Support‌ and found a setup that allowed it to work. Also from support, "We do support mobile browsers and have found that this issue can be resolved for Safari by turning off the "Prevent Cross-Site Tracking" option in Settings > Safari > Privacy & Security. We were unable to reproduce this error in Chrome, and don't  see a similar setting to toggle."

I was able to find on my iPhone that going to Settings > Safari > Block Cookies > I changed my setup from Allow from Websites I Visit TO Always Allow.

Doing this allowed my Nintex Responsive form to appear and submit in the Safari browser. 

On the iPad, to set this up as described by Support, the example looks like this,

Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

What iOS version are you using?  I am on 11.0.3 and don't have the same options.  It may also be MDM related but I think it is version related.  Thanks...

0 Kudos
Reply
Workflow Hero

Re: When we try to navigate to the form throught the Iphone I recieve "Enable cookies"

Jump to solution

In 11 you may see the Prevent Cross-site tracking option. Make sure it is off. My phone is still on final version of 10.

0 Kudos
Reply