cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
acipolla
Nintex Newbie

Set O365 form field to read-only after form submission

Jump to solution

Is it possible to make a people-picker name field read-only after form has been submitted?  In our process, "Submit" sends the form into an approval workflow based on the reporting structure of the person in the "Name" field.  We've just learned that users can and do make name changes within the form, essentially negating the previous approval loop.

Any help would be greatly appreciated.  Thanks in advance!

Labels: (1)
Tags (1)
0 Kudos
Reply
8 Replies
shaunlub
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

Anne,

I would recommend making the People Picker control only active on the New Form.

In the Control Settings, under Apperance=> Visible, select Expression, and then enter isNewMode from the functions.

You could have a Label or Calculated Value control hidden behind the People Picker, which will display the contents of the column where the People Picker is saving the Name.

So - in New Mode, a name is selected; when submitted, that name is only visible in the un-editable Label or Calculated Value control.

0 Kudos
Reply
acipolla
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

Thank you, shaunlub, that makes sense.  Got the people picker to display only in New Mode but can't seem to get the employee name to populate from People Picker to Label or Calculated Value control.  Would you mind providing some direction?  Sorry to be needy, I'm still quite new-ish to Nintex.

Many thanks!   

Reply
shaunlub
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

The settings for the People Picker should be similar to this:

The setting for the Calculated Value control would be similar to this:

Employee Name is the SharePoint People/Group column (so the People Picker is connected to this - saves input to this column).

The Calculated Value just pulls this in when the form is opened. If Recalculate Formula on View Mode is set to No, this will be empty when you open the form in display mode after submitting - so this needs to be Yes.

There is a learning curve for everything. Questions make learning curves shorter. Have fun.

0 Kudos
Reply
acipolla
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

That did the trick!  Thank you so much, shaunlub!!

Reply
acipolla
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

Hey shuanlub.  We encountered a bit of a problem with the calculated value solution.  Because the control is not connected to a list column, if a request is opened after submission and another field edited, the traveler's name is removed from list view.  And because the Employee Name column is a people picker field, it is not available in the 'Connected to' options for the calculated value control (nor would it be for a label).  I've been unable to find a solution that both shows the traveler name on the form and does not remove it from the SP list.  We're supposed to roll this out next week.  Yikes.  Any suggestions?  Thanks so much!!

Reply
shaunlub
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

The People Picker needs to be attached to a People/Group column to be able to user the SharePoint profile to access Display Name, Email Address, etc.

So, I would recommend using only the Calculated Value to pull in the logged-in user's display name and save that out to a text column. You would not be able to enter another name, though.

The settings would be:

0 Kudos
Reply
kiran_bellala
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

Did you try break permission inheritance and update permissions in the workflow?

0 Kudos
Reply
acipolla
Nintex Newbie

Re: Set O365 form field to read-only after form submission

Jump to solution

There are several instances of activity-level permissions settings in this workflow, I'm afraid that won't help in that case.  Thank you for the suggestion!  

0 Kudos
Reply