cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Repeating section default values

Jump to solution

Hello,

I've created a form for logging work hours where people enter the time they've spent on various tasks. It uses a repeating section - they create a new instance for each day.

The fields are all decimal and have a default value of 0.

When you create a new instance of the form this is all fine - each instance of the fields has them all set to 0 until the user replaces that with another value. However if you save and close the form and then return to add another instance of the repeating section all the fields on the new section are empty - they don't have the 0 in them.

Is there a way to make the fields contain 0?

Labels: (1)
Reply
5 Replies
Workflow Hero

Re: Repeating section default values

Jump to solution

Hi,

What is meant by "if you save and close the form and then return to add another instance of the repeating section all the fields on the new section are empty - they don't have the 0 in them" ? Is the user adding new row by clicking "Add Row" ? Also please share screenshot if possible.

Thanks,

Krishna.

0 Kudos
Reply
Workflow Hero

Re: Repeating section default values

Jump to solution

Hi Krishna,

So, if you create a new form, you can click on the "Add row" button and all the fields in the repeating section appear with a default values of 0, which is what I want them to do.

However if I save a form, then go back later to edit it, when I click "Add row" (or in my case "Add new day") the fields in the repeating section appear, but they are all empty. I would like them all to have 0 in them as per the default values I set up. I've done a couple of screen shots to show what I mean.

Here's what happens when I add a new row in a new document:

All values set to 0 in new instance of section

Here's what happens when I add a new row to an existing document that I've put into edit mode:

All values blank in new instance of the section

Thanks,

Alice.

0 Kudos
Reply
Workflow Hero

Re: Repeating section default values

Jump to solution

Hey Alice,

Since the form is submitted, it technically doesn't have a default value anymore. The new rows become Null. Try adding a 0 to the Null display text in the Control Settings.

Reply
Workflow Hero

Re: Repeating section default values

Jump to solution

Thank you Chadd, that works perfectly.

Alice

Reply
Workflow Hero

Re: Repeating section default values

Jump to solution

No problem! Glad it worked. Mark my reply as correct when you get a chance!

0 Kudos
Reply