cancel
Showing results for 
Search instead for 
Did you mean: 
anissa_divincen
Nintex Newbie

Problems with getting data out of a Collection Variable

Jump to solution

I am having problems with getting data out of a collection variable.  At first I was using a complex collection variable which was populated by a List query and returning 4 different columns and their values.  Since I couldn't get out any of the data, I then changed my query to just return on 1 column of data.  There is only one row that is returned with my test query.  

 

Here is my problem, I can't get the data for my item out of the collection.  I have a For Each on the collection and it that I use Get Item from Collection.  When I do that I get the error: Index must be 0 or greater.  Doesn't matter if I hard code a 0 into the value field, or a 1, or use a interger variable set to 0, I still get that error.  I even tried to run the Get Item from Collection on it's own and then I get the error: Index property is greater than the number of items in the collection.

 

Here is my collection variable from my history log: [{"FUND_x0020_TITLE":"475 - CULVER CITY PARKING AUTHORITY"}]

 

What am I missing?  I am new to Nintex but have used a collection variable before and got my data using Get Item from Collection.  

Labels: (1)
Tags (1)
0 Kudos
Reply
3 Replies
Community Manager Community Manager
Community Manager

Re: Problems with getting data out of a Collection Variable

Jump to solution

I completely understand this can be frustrating.  You marked this with forms, so I'm curious is this a workflow or forms issue. 

 

If possible, could you export your workflow and share it here. You may have to zip it in a folder to upload. I'll personally look into this for you. Also a sample of your list or form structure would help to make sense of your inputs for the collection. 

 

Thanks,

Eric

0 Kudos
Reply
anissa_divincen
Nintex Newbie

Re: Problems with getting data out of a Collection Variable

Jump to solution

Here is the workflow in it's latest state.  And yes, I  should have put Workflow and not forms, thanks for noticing that.

0 Kudos
Reply
anissa_divincen
Nintex Newbie

Re: Problems with getting data out of a Collection Variable

Jump to solution

This problem must have been intermittent as things are now working as expected.  It happened again to me where it wouldn't work and then later worked.  Not sure why.

View solution in original post

0 Kudos
Reply