cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Mandatory fields ignored on published form but ok on preview

Today I am seeing a confusing behaviour (Office 365 Nintex Forms):

- I have a content type with several fields that are REQUIRED

- I design a Nintex Forms (keep default generated)

- Preview its design and I can see all the fields that are required do not  let me save, that's good

Nintex_Forms_for_Office_365.png

Now I publish the form and click NEW - and select my Content Type name

I check which fields are mandatory ... only the title.

Published_form_issue.png

I have check the Content Type several times to make sure the columns are REQUIRED and they are.

I reseted the form to default, even delete the form and checked with the standard SharePoint form which shows the mandatory fields correctly, so it seems to be down to my Nintex Forms having an issue.

note: this behaviour is the same in Nintex Mobile too

Labels: (1)
Tags (1)
0 Kudos
Reply
5 Replies
Not applicable

Re: Mandatory fields ignored on published form but ok on preview

Hi Francois,

Our initial investigations indicate that this could be a bug. The Development Team is investigating further and if it turns out to be a bug, it will be fixed and released shortly.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Mandatory fields ignored on published form but ok on preview

OK thank you. however this should affect all forms or may be only newly designed Nintex Forms which is why I saw it only in 1 form yet.

If you need me to test furthermore let me know.

0 Kudos
Accept as Solution Reply
Not applicable

Re: Mandatory fields ignored on published form but ok on preview

Hi Francois,

Would be great if you could test this on the existing forms which use content types and confirm if you experience the same issue.

Thanks

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Mandatory fields ignored on published form but ok on preview

There is definitely something strange in the behaviour.

I re-publish the form that was created back in April and has all fields mandatory, as you can see field 3 is mandatory on submit, but before clicking submit it is missing the little red star to show the mandatory state,

Nintex_form_O365_mandatory_fields.png

although the Content Type is definitely showing these columns as required.

Content_Type.png

0 Kudos
Accept as Solution Reply
Not applicable

Re: Mandatory fields ignored on published form but ok on preview

Hi Francois

Our development team confirmed that the fix for this issue will be included in our July's release.

Thanks

Gorica

Accept as Solution Reply