cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

List workflow doesn't start if item created from another workflow

Hey Guys,

Probably something simple I'm missing here.

I have a calendar with a workflow (W1) that emails users when a new item is added. This works great if the item is manually added by a user.

However, if I create an entry in the calendar from within another workflow (W2), the list item workflow (W1), mentioned above, does not start.

I'm assuming I've done something wrong or this is a limitation of Sharepoint (O365) or Nintex.

Can anybody shed any light on this?

I appreciate that I could call the list item workflow (W1) from W2, but would rather not.

Many thanks for any help.

Chris

Labels: (1)
0 Kudos
Reply
9 Replies
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

I think that this is a Sharepoint 2013 Online issue.

It's know that the same issues is present on another OnLine content Types, for example it is a know issue on Document Set. Some contents on Sharepoint 2013 Online fires event different from lists and libraries.

Perhaps you have the chance to validate it also creating a Sharepoint designer workflow.

In that case I suggest to post a case on Microsoft support.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

Hi Christopher Wells​,

Are you using the "Create List Item" action? or you can try to use "Office 365 Create List Item or Document Set" action

0 Kudos
Accept as Solution Reply
Not applicable

Re: List workflow doesn't start if item created from another workflow

The way I got around this was to use the 'start workflow' activity in the first workflow, right after creating the item:

Create the item -> get the Guid of the newly created item -> start the workflow on the newly created item

Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

From  what I understand W2 will not start automatically if the item is created by W1.  Nintex claims that this is the way SharePoint Online is designed.  Workflows use the 'system' account when creating items and this account cannot start workflows.  This is regardless of the credentials you enter in the create item dialog.  Workflows will only start automatically if the item is created by a user....

Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

Great explanation, this is correct in how the item is created. Use the work around than Dan describes to then start the workflow after item creation

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

I have this same issue with SharePoint (SP) on premise, not SP online O365, except that I am creating an item in another list.  Anyone have a work around for getting a workflow to run on an item created in another list?

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

You should be able to do this on prem. Make sure the item created is by a user account and not farm admin or system account. I've seen that cause workflows not to start. 

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

Okay, the thread was referring to the SharePoint limitation of creating item via workflow, because it uses the System account to create the item.  So yes, the item is being created by system account.  I have workflow in one list creating new item, in another list.  The other list has a workflow that runs on new items.  I need this workflow to run on these workflow created new items.  Any idea how to get the workflow to start without manual intervention?  Is there a run as option?  Or some way to force that?  Under what user do site workflows run?  I could use site workflow, just not sure what I would use as my selection criteria.

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: List workflow doesn't start if item created from another workflow

Alright...I am totally embarrassed to admit this, but it was user error.  I didn't import the workflow to the 2nd list in dev, (the workflow that wasn't starting).  It is working as required, now that there is a workflow to start, with no additional configuration...thanks for the help, Andrew.

Accept as Solution Reply