cancel
Showing results for 
Search instead for 
Did you mean: 
Workflow Hero

Issues with publishing workflows

Jump to solution

Today, we are noticing issues while publishing workflows. These workflows worked yesterday. But we could not publish today.  Is this due to Task id change?

Does anyone else see similar issue while publishing an already published O 365 workflows?

Tags (1)
Reply
9 Replies
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

Try reverting the changes made and then publish it ?

Does it still throw the same error ?

You can even try exporting / importing the workflow

0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

What do you mean by Task id change?

0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

 

0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

Hi!

No, that certainly isn't caused by the new feature.

I would rather look back to the changes you have made. Maybe you have an action that lost relation to a variable? Or you changed something in your SharePoint, ex. field from single option, to multiple options?

Can you revert your changes, publish workflow, and then proceed with them step-by-step looking what's causing the issue?

When I have such problem, I do the following:

  1. Export the workflow (backup)
  2. Then remove huge blocks of actions - like "run if", "switch", conditional blocks etc... 
  3. After each removal try to publish your workflow.
  4. When you are able to publish, import the workflow again (from the backup, from step no. 1) and try to remove smaller blocks of actions.
  5. And finally, having that sort of elimination, you should be able to track down the single action causing the issue.

You can as well check the https://status.nintex.com/ - maybe something was wrong with the designer service at that moment?

Regards,

Tomasz

Regards, Tomasz Poszytek
0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

Hi Kiran,

I have the same exact error sinds 04/10. The error also occured after I tried using the new Task ID functionality with the Task process action. 

I've tried to create a collection in the Task process settings and got the following warning: "Command: undefined - process". Thinking that something went wrong I checked all my variables and I could see the newly created variable there. I thought this was strange so I've removed the variable and then remove the Task process action. 

Since then I can't publish my workflow anymore... Didn't do anything else besides adding this action and collection variable.

I've opened a support ticket and they are looking in to it. I'm "glad" I'm not the only one running into this problem.

0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

Received this email from support team:

Our Dev team has found the following:
Issue was related to action changes on "Actionable Emails" and "Task ID" changes.  We have since removed these features and those workflows that had it will need to be republished.

They did confirm that the issue was due to new changes pushed on Oct 3. But I think this was nor affecting all tenants. 

0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

My bad  I was sure they did regressions tests

Regards, Tomasz Poszytek
0 Kudos
Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

This morning I noticed this message on workflow designer screen:

Fix for the issue is to just republish the workflow. I was able to republish and everything went well! 

Also the task id screen is back to original format (no radio buttons for Task GUI and Task id).

Good job for a quick turnaround 

Reply
Workflow Hero

Re: Issues with publishing workflows

Jump to solution

‌ i think you should mark your last answer as correct, as it most completely answers your own problem  Do you agree with me?

Regards,

Tomasz

Regards, Tomasz Poszytek
0 Kudos
Reply