cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Workflow Hero

Issues with Site & user administration connection

Jump to solution
My company recently migrated to SharePoint Online and I'm working on updating my Nintex on-prem workflows to work in Nintex O365.  I have a simple workflow where I'm trying to user the Office 365 Query User Profile action to get a persons First and Last Name.  However I can't figure out how to get this thing to work, and I believe the problem is with the connection that I have to setup for the action. 

I created a Site & user administration connection and am using my company email as the Username, which based on this article seems to be what I need to do.  However every time I run the workflow I get the error, "The username is invalid or does not exist, or the password is invalid for the username specified."  

The Intenral Status field value is "Suspended", and when I click the info icon this is the message I see.
 Nintex O365 Site and User Administration Connection Issue_01.png

The credentials I'm using in the connection are my own, and I'm logged in with the same account.  I'm a site collection admin for the site, and also validated that I'm listed as an owner on the sub site the workflow is running on. 

Anyone have an idea what the problem may be?  I'm wondering if there is some setting that our SP admin team needs to update for this to work, but haven't been able to find anything to indicate that.  I'm stumped at this point.  Suggesstions?

 

Labels: (1)
0 Kudos
Reply
4 Replies
Workflow Hero

Re: Issues with Site & user administration connection

Jump to solution

Have you grant acced to your workflow to the user profile ?

You can do it in following this step : 

- Go to site and Content

- Open apps : "Nintex WOrkflow for Office 365"

- Go to Settings -> General

 

Grant Access.png

Reply
Workflow Hero

Re: Issues with Site & user administration connection

Jump to solution

I have not.  Didn't even know that was a thing that needed to be done.  And when I try to do it, it says my tenant admin has to approve it.  I'll shoot this over to our admin team and see if this fixes it.  Thanks for the suggesstion @nico.

0 Kudos
Reply
Workflow Hero

Re: Issues with Site & user administration connection

Jump to solution

I just noticed that the description for this authorization says it's needed for "This access is required for workflows to resolve manager references, such as Manager login name."

 

I'm not looking up any manager references so would this still be needed in this scenario?

0 Kudos
Reply
Workflow Hero

Re: Issues with Site & user administration connection

Jump to solution
This is only written because manager is available by default in the "worfklow context" properties, but this is needed for the other properties too.
0 Kudos
Reply