cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Hyperlink to Form Not Opening Correct Form

So what you are supposed to be able to do is open a specific form by referencing its content id in the url string. This works....sometimes. what i typically do is something like this:https://SITENAME/Lists/Projects/EditForm.aspx?ID=ITEMID&ContentTypeId=CONTENTTYPEID

This is farily straightforward, however there are times when it opens a different form. It usually appears to be the last form opened or edited...

Has anyone seen this or does anyone know of a better way to create a link to a specific content type/form?


Thanks,

0 Kudos
Reply
3 Replies
Highlighted
Automation Master
Automation Master

Re: Hyperlink to Form Not Opening Correct Form

Hi Nick,

Make sure your &ContentTypeId= is correct and well formatted like this

0x01009F94353311B8E0479DCF50DBB99B52E202001001AD5F0A6CCA44B1BDF5E0BC25AB97

Best regards,

Christophe

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Hyperlink to Form Not Opening Correct Form

I am using the full content type. It does work fine for a period, then for some reason it no longer works. The content type in the url is correct, but it actually opens a different form, attached to a different content type.

To correct, I can go in to the edit the form that is not opening properly and publish again. When I do this, and go back and click the very same link, it opens the proper form. This is a very serious concern regarding my solution, so looking for some help here...

Thanks,

0 Kudos
Reply
Highlighted
Automation Master
Automation Master

Re: Hyperlink to Form Not Opening Correct Form

Hi,

You can also try this url:

https://SITENAME/_layouts/listform.aspx?PageType=6&ListId={LISTID}&ID=ITEMID&ContentTypeID=CONTENTTY...

You can find the listid using this tip

Maybe it is more stable

Regards,

Christophe

0 Kudos
Reply