cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

hello


Today is my first day using Nintex in O365, its a bit different but think I am getting there!

On the first workflow I am creating I receive an error

One or more field types are not installed properly. Go to the list settings page to delete these fields.  'Workflow History'

This is just a normal list, as you can see I do not have a workflow history field....I am stumped.

This is the workflow

this is the query if that helps, then I am just emailing the variable to myself.

<View>

    <Query>

        <ViewFields>

            <FieldRef Name="Title" />

        </ViewFields>

    </Query>

    <RowLimit>100</RowLimit>

</View>

Reply
20 Replies
Not applicable

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Jamie,

The error "One or more field types are not installed properly. Go to the list settings page to delete these fields. " represents a failure in a CAML query. Its more than likely you are receiving this error due to one of your column names on this list being mistyped and/or renamed. Please review your list column names under list settings and verify the links reflect the correct column names.

For example, in my screenshot I created a column named "Test" and changed its name to "TestBroken". As you can see in the URL the column name retains the SharePoint "internal" name which is the original name of the column.

2015-05-12 14_25_35-List Settings - Internet Explorer.png

Please review your columns to ensure there is not a mismatch in your list columns.

Cheers,

Andrew Beals

Accept as Solution Reply
Not applicable

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Hi Andrew


Thanks for the quick response & example. Although I understand what you are saying that doesn't seem to be the case.

We just created a custom list, the only column that has been created is the Artcle Workflow column when the workflow ran for the first time. The 'Title' column has not been touched (that is the column in the CAML query) The error seems to be this 'Workflow History' field but there is no such field in the list unless it is hidden somehow? This is a brand new Tenant, New site, new list, Nintex app was installed on it 2 days ago. We are running the Nintex 30 day trial version if that makes a difference?

I have created a new custom list in a new site collection, built the same workflow (query list to extract title and send in email) but get the same error when running.

Thanks

Jamie

Accept as Solution Reply
Not applicable

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Jamie,

Please open a support case so we can review this issue inside your tenant as it seems to be isolated to your tenant only. Please mention your post in your case so we know the context of your question.

Thanks,

Andrew Beals

Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

I am seeing the same error message when using a new custom list (with no added custom columns) and a simple WF that just sends an email to me.  The workflow completes successfully, but displays this error in the history.  I did notice that the OOTB columns (Created By and Modified By) show a mismatch between the column Name and what you see in the URL.  Could they be the cause?

Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Was there any follow-up on this error message that is showing on a custom list when the workflow runs succesfuly ?

The previous answer explaining the possible case due to the difference between columns Display Name and System Name may have been a lead but doesn't make sense since it is a standard practice to have a System Name such as "MyItemDescription" and the Display Name as "Full Item Description" so this cannot be an issue with Nintex workflow  showing this informative message.

Any other idea from Nintex employees who surely must have seen that message too often?

Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Any progress on this error? there should be a more detailed error somewhere

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Hi I can see the same error when trying to customize a list for with nintex forms on a publishing site. It is a brand new site with a brand new custom list that has only the default title column. 

0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

Hi, have you solved your problem? Can you share the solution with us?

Best regards,

Tomasz

Regards, Tomasz Poszytek
0 Kudos
Accept as Solution Reply
Workflow Hero

Re: Error:One or more field types are not installed properly. Go to the list settings page to delete these fields.

It is not a Nintex Error, see this: Common error messages in SharePoint workflow development 

The workflow could not update the item, possibly because one or more columns for the item require a different type of information

This error commonly results from one of two situations:

  • One of the list fields was removed or changed, but the workflow was not updated to account for the change and is therefore trying to set a value for the old field. You should check all Update List Item actions in your workflow and make sure they are setting appropriate values for fields and that those fields exist on the list.

  • There is a data type error wherein the workflow is trying to set a value in a field in the list item using the wrong data type. You should confirm that the Return Field As operation in their lookup is of the correct data type.

0 Kudos
Accept as Solution Reply