rockroll
Nintex Newbie

XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

The root of my issues with the repeating fields is the values not translating to XML correctly from my Nintex O365 Form. For some reason it's not capturing the tag name in the multi-line (plain text) field. This is what I am getting:

<?xml version="1.0" encoding="utf-8"?><RepeaterData><Version>1.0</Version><Items><Item><_XHHR2gBRLmb type="System.String">sadcsd</_XHHR2gBRLmb></Item><Item><_XHHR2gBRLmb type="System.String">sdcsdcsdc</_XHHR2gBRLmb></Item><Item><_XHHR2gBRLmb type="System.String">sdcdscscsc</_XHHR2gBRLmb></Item></Items></RepeaterData>

When it should be:

<?xml version="1.0" encoding="utf-8"?><RepeaterData><Version>1.0</Version><Items><Item><Account type="System.String">sadcsd</Account ></Item><Item><Account type="System.String">sdcsdcsdc</Account ></Item><Item><Account type="System.String">sdcdscscsc</Account ></Item></Items></RepeaterData>

Account being the name of the column. Do you have any suggestions? For some reason the column name isn't coming over.

0 Kudos
Reply
5 Replies
leighburke
Nintex Employee
Nintex Employee

Re: XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

@rockroll That is expected behaviour when using new responsive forms, you should still be able to parse or make changes based on the ID(</_XHHR2gBRLmb>). What are you looking to do with the repeating section data?

 

 

View solution in original post

0 Kudos
Reply
rockroll
Nintex Newbie

Re: XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

Thank you for your reply! I wanted to use those values to populate a pdf using document generation. So those values will be used in the workflow.

0 Kudos
Reply
leighburke
Nintex Employee
Nintex Employee

Re: XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

@rockroll You will need to use a query xml and collections to pull out the repeating section data as mentioned here(https://community.nintex.com/t5/Nintex-for-Office-365/New-Responsive-Form-Display-data-from-repeatin...).

0 Kudos
Reply
rockroll
Nintex Newbie

Re: XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

Thank you for the info, as I have the workflow put together now. It's just what to do with the XML before I get it to the workflow. It sounds like I will need to parse and replace the weird value with the actual one, and then start with the document generation process.

0 Kudos
Reply
rockroll
Nintex Newbie

Re: XML created from repeating field in Nintex 365 form not displaying correctly

Jump to solution

What I did was use the system generated tag name in the workflow and it's working!, i.e. using _XHHR2gBRLmb

 

Thank you for your replies.

0 Kudos
Reply