Kneko
Canvas Initiate

Workflow tasks status stay in "Not Started" condition

Hi!

 

I have a workflow with some Assign Flexi Task. All Flexi Task sends e-mail to members of a group. There are about 10-20 members of the group. When the e-mail arrived to the members, I checked the Workflow Tasks list and these e-mails tasks status still in "Not Started" condition. Only two e-mail tasks status change to "In progress" condition. If I wait about half an hour or one hour the other tasks status will be changed to "In progress", but not always. It often takes several hours for the status to change. And the more members a group has, the slower the status of tasks changes. 

 

This is not a one-time problem, it always happens.

 

Has anyone else encountered this problem?

 

Thanks for the help!

0 Kudos
Reply
3 Replies
nico
Process Pupil

Re: Workflow tasks status stay in "Not Started" condition

Hi,

When a task is created and sent, his statut will always be "Not Started" (the task has not yet been completed).

When a assigned user make an update on the task, it will be in statut "In Progress".

When a assigned user complete the task, it will be in statut "Completed"

 

If on your task form, you just have a button of type "Save", your user will not be able to complete their tasks. (they will just make an update on the task)

You must have a button of type "Save and Submit" to be able to complet a task, it's the only way. 

After a task have been complete (or all the tasks, depending of the Assign Flexi Task parameter) your workflow will continue to run.

 

 

 

0 Kudos
Reply
Kneko
Canvas Initiate

Re: Workflow tasks status stay in "Not Started" condition

Thanks for your answer. I understand this part. 

But if somebody do something with a task when this task status is "Not Started" then they got "Something is went wrong" error message.
And then they can't do anything with this task.

Do you have any idea for this problem?

0 Kudos
Reply
nico
Process Pupil

Re: Workflow tasks status stay in "Not Started" condition

I think there is somthing wrong (a bad configuration) on your task form.

Maybe you outcome field on the task form.

 

If you reset your task form, can you valide/save the task ?

0 Kudos
Reply