wholani
Scholar

Workflow O365 Status value

I have two workflows in a SPO list and part of one of the looping workflows it checks to see if the other workflow is already running. 

I have varWorkflowStatus - Dictionary, then 'Get an Item from Dictionary' action, Key was "Description" then output was varWorkflowStatus2 - Text, then have a "Conditional Branch" action if varWorkflowStatus2 equals 'Started' then "Terminate workflow" but it isn't pulling anything back, I've checked the history logging and all it says (") without brackets. So it always thinks it's not running.

 

This workflow is 2 years old so not sure if there's a new way of doing this now?

 

 

0 Kudos
Reply
4 Replies
leighburke
Nintex Employee
Nintex Employee

Re: Workflow O365 Status value

@wholani How are you getting the status of the other workflow to put into the dictionary? Have you confirmed it exists in the dictionary.

0 Kudos
Reply
wholani
Scholar

Re: Workflow O365 Status value

Hi @leighburke,

Sorry I don't know how they're in there, I've inherited responsibility of this workflow. Is that under the Variables button next to Settings? or should I look for a build a dictionary action somewhere? How would I check if it exists in the dictionary?

Thank you,

Will

 

0 Kudos
Reply
leighburke
Nintex Employee
Nintex Employee

Re: Workflow O365 Status value

@wholani  As you mentioned I would be looking for the build dictionary action or where that variable is being set. You could add a log to workflow details action and put the dictionary variable in it to see the value.

0 Kudos
Reply
wholani
Scholar

Re: Workflow O365 Status value

Hi @leighburke ,

 

Thank you!

I'll contact support i think it might be a bug.

I was able to replicate the issue on a test subsite.

When setting the workflow status there's a set workflow variable looking up that column (same name as the workflow name) it seems to be happy and successfully publish but then when you close and open/edit the workflow again it's got the exclamation point against the set workflow variable.

I put in log to history looking up the variable and it's pulling data against the variable set.

 

Thank you again for pointing me into the right direction.

0 Kudos
Reply