TomaszPoszytek
Automation Master
Automation Master

Re: How to create a site using web service calls?

Jump to solution

Please, look into an example I attached. There is also a "Call HTTP web service" action that s working (is returning 401 ).

I guess something is wrong with the JSON (or dictionary in case of Call HTTP and SharePoint Designer approaches)  - look into my example, you will find there how should be the dictionaries built.

Regards,

Tomasz

0 Kudos
Reply
kmcollins
Nintex Observer

Re: How to create a site using web service calls?

Jump to solution

Hi Tomasz,

Thanks for your help - I can confirm that at least create group and assign permission to group web requests are working. Those were not working until I gave the workflow app permission to the entire site collection, not just subsites and then they started to work. I thought the same would be true for create site, but it appears not. 

Kind regards,

Katherine

0 Kudos
Reply
kmcollins
Nintex Observer

Re: How to create a site using web service calls?

Jump to solution

So, I have a solution to this issue:

The web request action wasn't working inside the app step. Remove the app step, and it now creates a site using exactly the same service call...go figure

Thanks to all for their help,

Katherine

View solution in original post

0 Kudos
Reply
TomaszPoszytek
Automation Master
Automation Master

Re: How to create a site using web service calls?

Jump to solution

 Weird... I was not using the app step. It didn't work in my case without  being inside the app step Maybe it was rather related to other kind of issue, and it was fixed in a meanwhile

0 Kudos
Reply