cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Nintex Newbie

Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

A list on SharePoint 365 has multiple content types. Nintex Online supports nicely the creation of multiple forms. But in Nintex Workflow Cloud a Create List Item action keeps the Add Fields button greyed out on this list? Are the multiple content types the reason for this?

2020-09-29_16-51-14.jpg

Labels: (1)
0 Kudos
Reply
6 Replies
Highlighted
Nintex Employee
Nintex Employee

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

@woutert Multiple content types should work, just tested and confirmed. Have you tried just reopening the workflow or refreshing the lists.

Reply
Highlighted
Nintex Newbie

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

Thank you @leighburke for taking the time to test it even. Well, after a day of searching and testing I think I found a possible minor bug. I usually create a list with a name without spaces to keep a tidy URL e.g. ContentPackages. Then I change the name by adding a space to have nicer pages: Content Packages. When you do this the error as I described occurs. After changing the name back it works again. I noticed that it happened with all lists that had double word names. If this is a minor bug I hope it can be corrected.

Reply
Highlighted
Nintex Newbie

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

Well done @woutert 

as a life long lover of URLs with no %20's I do this all the time when creating lists and libraries.

 

Great pickup also hope the bug is addressed soon.


Cheers

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution
Not just for spaces but for any change in the name I notice. Keep URL and list name identical if you want the Data sources to work.
Reply
Highlighted
Nintex Employee
Nintex Employee

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

@woutert  Are you able to replicate the issue consistently, I would be raising this with our support team. I just tried and was unable to replicate issue but I may of missed something.

0 Kudos
Reply
Highlighted
Nintex Newbie

Re: Is the SharePoint connector supporting multiple content types on a list?

Jump to solution

The name of this topic no longer applies. It all seems to come down to a glitch in the Data Sources page. I was able to replicate the error on a test list today easily.

First created a list in SharePoint online:

2020-10-02_9-13-30.jpg

Then tried to create a data source in NWC:

2020-10-02_9-12-35.jpg

All fine so far.

Now renamed the list:

2020-10-02_9-15-02.jpg

And refreshed the Data Source page and then tried without success:

2020-10-02_9-16-34.jpg

How can it be that this happens to me but not to you? After some more investigation this morning I think the difference might be in one slash '/'. I put a slash at the end of my SharePoint site URL as I learned from some Nintex demo videos. But when I don't things behave different suddenly.

2020-10-02_9-23-44.jpg

With the slash the new given name appears in the pull down list and no columns available.

2020-10-02_9-45-37.jpg

Without the slash it shows me the 'original URL name' and the columns are available again.

Sorry to bother you with such a detail but it did cost my a lot of time and I am sure it will save others time when corrected.

 

View solution in original post

Reply