cancel
Showing results for 
Search instead for 
Did you mean: 
DorjeM
Nintex Newbie

How to display NinTex Widget in SharePoint online modern page

Jump to solution

We have a SharePoint Online classic page.

It contains two pageviewer webparts, one links to 
https://go.promapp.com/<ourCompany>/sharepoint/widget.aspx?notifications=true&logo=true&recent=true&...
And the other links to
https://go.promapp.com/<ourCompany>/Dashboard/Governance

 

We are transitioning to Modern SharePoint pages for our content (which use the SPFx framework, so we can't use the old webparts).

In modern sharepoint pages the Embed webpart should achieve the same function...... BUT even though we have enabled "Site settings/Html field security" to allow embeds from go.promapp.com the Modern SharePoint pages won't accept the URLs above.

Does anyone at Promapp or in the forum know how to make this work ?

We suspect that there is something on the Promapp end which is causing the modern sharepoint page Embed webpart to fail and not allow the URLs to be used. Possibly too many redirects or some other non-obvious issue.

Your help would be appreciated.

Many thanks

Labels: (1)
0 Kudos
Reply
2 Replies
jamesRoss
Nintex Newbie

Re: How to display NinTex Widget in SharePoint online modern page

Jump to solution

For the Promapp pages, you are best to use the iframe to display them on your SharePoint pages.

 

Try the following code:

<iframe width="260" height="190" src="https://go.promapp.com/<yourcompany>/Sharepoint/Widget.aspx?notifications=true&search=true&recent=true&favourites=false" frameborder="0" allowfullscreen></iframe>

0 Kudos
Reply
DorjeM
Nintex Newbie

Re: How to display NinTex Widget in SharePoint online modern page

Jump to solution

Hi @jamesRoss 

Thanks for the post.

I'd tried something similar but your iFrame syntax worked on a SharePoint Online Modern page.

The only thing that might have helped is that the "Site settings/Html field security" for the site collection the page is in may not have had time to synchronise, and it may be that which was causing my issue.

 

Anyway - we've not got a modern sharepoint page with a go.promapp.com iframe in it.

 

Many thanks

0 Kudos
Reply