No ratings

Workspace page not loading in full\correctly


Workspace page not loading in full\correctly after IE11 upgrade

This article was created in response to a support issue logged with K2. The content may include typographical errors and may be revised at any time without notice. This article is not considered official documentation for K2 software and is provided "as is" with no warranties.
This article has been archived, and/or refers to legacy products, components or features. The content in this article is offered "as is" and will no longer be updated. Archived content is provided for reference purposes only. This content does not infer that the product, component or feature is supported, or that the product, component or feature will continue to function as described herein.


This occurs after upgrading Internet Explorer to version 11.

The K2 Workspace no longer functions correctly and an error "This operation requires IIS integrated pipeline mode" appears.


When the pipeline mode is changed to integrated mode, a "500" error appears.




The issue is caused by the K2 URLs not being added on the trusted sites list, as well as the compatibility view site settings.


The K2 URLs are the workspace runtime URLs, as well as all the other base URLs used.

For example:

  • " * "
  • " * "

Troubleshooting Steps

Complete the following workaround:

Please ensure the document mode is set to "Edge" and add your K2 URL to the Compatibility view setting on the browser e.g ""




Then go to Internet Options and add the same site to the Trusted sites.

From the Trusted sites option, click on "sites" and add all your site URLs.


For example: "*"





Another workaround would be to use the option: "Set enterprise mode to True".


Labels: (2)
Version history
Last update:
‎03-15-2022 05:29 AM
Updated by: