arash
Scholar

Worklist item link not working

Hello,

 

I am using worklist item link from workflow context browser in Smart forms client event to generate approval link. It was working fine but from last few days this link ask for authentication when clicked. And I found this worklist item link in email is now pointing to https://servername/designer/runtime instead of https://servername/runtime/runtime. Any suggestions how can I fix or what could have cause this issue. 

The link works fine if I manually change link to https://servername/runtime/runtime

6 Replies
tedboeckman
Apprentice

Re: Worklist item link not working

That is likely a change in the environment template, make sure the URL you want is set as the default.

0 Kudos
arash
Scholar

Re: Worklist item link not working

what setting would that be?

0 Kudos
tedboeckman
Apprentice

Re: Worklist item link not working

the Environment template can be found in either K2 workspace or K2 management(4.7) sites, in there you can see all of the environment settings and what is set to the default.

0 Kudos
Kran
Apprentice

Re: Worklist item link not working

Hi  arash,

 

Refer Change K2 SmartForm Context Browser Environment field variable value using K2 Workspace

 

After doing this in smartform context browser under Environment  Fields expand  Smartforms Runtime URl and use Smartforms Runtime(default) to get this.

 

let me know if this helps you.

arash
Scholar

Re: Worklist item link not working

I just confirmed these settings and right field is selected as default but for some reason my worklist item link is still incorrect.

Looks like my worklist item link is made up of Smartforms designer runtime link instead of smart forms runtime link

 

0 Kudos
Kran
Apprentice

Re: Worklist item link not working

Hi arash,

 

You can edit this SmartForm runtime field value (refer link from previous post for same), as generally it contains URL for runtime site. But in case if don’t want to update this field value then you can create new field from workspace and set it as default.

 

Let me know if this helps you.

 

                                 5403iE66E1885352CC40C.jpg