Keith777a
Novice

Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

Hi All, I'm on a roll today, I think this is my third question for today.

 

OK am I missing something, in my Smartbox Smartobject I have a field that is just a memo field for writing a largish message.

When I use a View to Data Entry to the SmartOjbect I get the following error message.

 

I'm having a hard time working out why anyone would put a 100 character limit on a memo field, I could understand if it were a standard Text box field, must have seemed like a good thought at the time. I don't seem to be able to see anywhere that this arbitrary limit has actually been assigned. The underlying smartobject data field it also a memo field. 

 

My thought and it's obviously wrong is that a memo field should be longer than a text box

 

this is the error I get during data entry and believe me I didn't set this 100 character limit.

 

2071iD59D262668EA017C.jpg

 

Regards

Keith

0 Kudos
Reply
5 Replies
s0m3one
Apprentice

Re: Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

Strange issue, Can you go into the K2 database and look at the field limit size. It should be in the smartbox schema and the smartobject name should be the table name.

0 Kudos
Reply
tin
Apprentice

Re: Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

I believe this may be a bug in the "K2 Designer" web, when changing a field from text to memo.  Please use a thick designer and try the following:


 


1. Use a thick client designer (K2 Studio/K2 for Visual Studio)
2. Create a K2 solution and then use the "Save to Local" option to save this Smartbox Smartobject to the solution
3. Edit the property(s) having the issue and change it back to 'text' first and apply the change; then immediately afterward change it to 'memo' and apply the change again
4. Redeploy this Smartobject
5. If not already done so on the Smartforms side, also make sure that the control associated with this memo property is of type 'text area'
6. Retest

Reply
Keith777a
Novice

Re: Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

Thank you Tin

 

It was only a very small Smartobject with a few fields in it, when I saw in your response that it was changing from Text to Memo.

I remembered that that is what I had done, changed from Text to Memo.

 

I've just recreated the SmartObject in the Designer using the Memo field right from the get go.

Tested and that works.

 

Thanks so much you put me on the right track.

 

I would have used the K2Studio solution but I'm not as familiar with it.

I'll remember this for the future.

 

 

 

Regards

Keith

0 Kudos
Reply
Vishesh
Apprentice

Re: Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

Hi,

 

I have this king of issue with the SmartObject Max length 100. I did work around for this as well.

Instead of using the same field I have delete the column from smartObject Recreated same column with Memo property and magic worked.....

 

I think SmartObjects are chnaging only at front that is K2 Designer. I checked in the K2 database  for that SmartObject related table and in the Table Property the value type was not change at first. By implementing work around this error got fixed.

0 Kudos
Reply
Sharpharp1
Apprentice

Re: Smartbox SmartObject Memo maximum length 100 characters.

Jump to solution

Vish,

 

This worked, thanks.

 

I had this issue before and i remember this **bleep** big, I deleted the fields and recreated as MEMO from the beginning and it works...

 

When are K2 going to fix this bug? Its annoying if you don't remember the bug or the requirements change mid project..

 

0 Kudos
Reply