MrSafe
Apprentice

Smart Actions and o365 a Heads Up

This is a heads up for all those in the middle of moving email to o365.


 


If you are running K2 BlackPearl in an on prem environment, the chances are your spam filter settings for smart actions in hostserver.exe.config is set to the default which is accept from local domain.


 


If this is the case and you move mail boxes to o365 this will break smart actions, this is because the filter is looking at the email headers sending server info and when your mail boxes where on prem this would have matched the spam filter rule. o365 sending servers contain no information about your local domain and you will find that smart action throws a spam error in your event logs.


 


Unfortunately and recently confimed by K2, turning the spam filter off and adding <AuhtorizedDomains> to the relevant section on hostserver.exe.config will not help. You may be able to re-establish your smart action functionlity by the adding authorized domains found in the message header, but as far as I can tell and please chime in if I'm mistaken, these are shared tennacy addreses and adding these names will potentially open your smart actions account to anyone with o365 account, which is approaching the 100 million mark.


 


I raised a call #138744 and the advice is to implement the spam filter elsewhere such as in exchange as per this article:


 


https://technet.microsoft.com/en-us/library/aa996604(v=exchg.141).aspx


 


Thanks to Mustafa for the info in the ticket.


 


I hope this is found to be useful for the rest of the community.


 


 

Reply
1 Reply
StevePCollins
Novice

Re: Smart Actions and o365 a Heads Up

I wish I'd found this article months ago! From our experience we found that the spam filter was switched on by default, even though there were no specific entries in the hostserver config file. We had to explicitly put an entry in there to disable it.

0 Kudos
Reply